summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-04-06 07:54:02 +1200
committerKent Fredric <kentnl@gentoo.org>2017-04-06 07:54:17 +1200
commit43bd3a400b6cddb3896d3e59a7870f19d96de66b (patch)
tree3b95f677e31758c1e3c830bf809ce7f1d85d6dd0 /dev-perl/Path-Tiny/Path-Tiny-0.104.0.ebuild
parentsci-chemistry/ParmEd: Initial version (diff)
downloadgentoo-43bd3a400b6cddb3896d3e59a7870f19d96de66b.tar.gz
gentoo-43bd3a400b6cddb3896d3e59a7870f19d96de66b.tar.bz2
gentoo-43bd3a400b6cddb3896d3e59a7870f19d96de66b.zip
dev-perl/Path-Tiny: Bump to version 0.104.0
Upstream: - Fix bugs in relative symlink resolution - Detects circular loops in symlinks and errors - spew_utf8 accepts arrayref as input - Prefer PerlIO::utf8_strict over encoding(UTF-8) - 'touch' can now set current time on writeable unowned files - Symlink support detection always looks at $Config{d_symlink} - Add 'realpath' option to tempfile/tempdir - Fix '.' in @INC issues - 'absolute' always returns absolute paths even with relative base paths - Add 'cached_temp' Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'dev-perl/Path-Tiny/Path-Tiny-0.104.0.ebuild')
-rw-r--r--dev-perl/Path-Tiny/Path-Tiny-0.104.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-perl/Path-Tiny/Path-Tiny-0.104.0.ebuild b/dev-perl/Path-Tiny/Path-Tiny-0.104.0.ebuild
new file mode 100644
index 000000000000..ba20c35393e1
--- /dev/null
+++ b/dev-perl/Path-Tiny/Path-Tiny-0.104.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=DAGOLDEN
+DIST_VERSION=0.104
+inherit perl-module
+
+DESCRIPTION="File path utility"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test minimal"
+
+RDEPEND="
+ !minimal? (
+ >=dev-perl/Unicode-UTF8-0.580.0
+ )
+ virtual/perl-Carp
+ >=virtual/perl-Digest-1.30.0
+ >=virtual/perl-Digest-SHA-5.450.0
+ >=virtual/perl-Exporter-5.570.0
+ >=virtual/perl-File-Path-2.70.0
+ >=virtual/perl-File-Spec-0.860.0
+ >=virtual/perl-File-Temp-0.190.0
+ virtual/perl-if
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.170.0
+ test? (
+ !minimal? (
+ >=virtual/perl-JSON-PP-2.273.0
+ dev-perl/Test-FailWarnings
+ dev-perl/Test-MockRandom
+ )
+ >=virtual/perl-Test-Simple-0.960.0
+ )
+"