summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Perlbal
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Perlbal')
-rw-r--r--dev-perl/Perlbal/Manifest1
-rw-r--r--dev-perl/Perlbal/Perlbal-1.800.0-r1.ebuild49
-rw-r--r--dev-perl/Perlbal/files/Perlbal-1.58-Use-saner-name-in-process-listing.patch34
-rw-r--r--dev-perl/Perlbal/files/perlbal_conf.d_1.585
-rwxr-xr-xdev-perl/Perlbal/files/perlbal_init.d_1.5825
-rw-r--r--dev-perl/Perlbal/metadata.xml63
6 files changed, 177 insertions, 0 deletions
diff --git a/dev-perl/Perlbal/Manifest b/dev-perl/Perlbal/Manifest
new file mode 100644
index 000000000000..ace86fbafb4d
--- /dev/null
+++ b/dev-perl/Perlbal/Manifest
@@ -0,0 +1 @@
+DIST Perlbal-1.80.tar.gz 212701 SHA256 179e1d8a8106d7a18cd0718c7c53a066b4b557350c29eb5e08eb2ccecb00f16c SHA512 22d9fc9c92a85dce662a3d042fa6a3aa0fc942d935d95b87094a38961a2e72396cbc45eada80112eabb019a89b845b73a8e1d7720f3799bdbbe185e1404442e7 WHIRLPOOL adc2799f686325e22c29cd8e8f076455e3f99fa2244359c8e974ae3e55e840fc5b511b16252e947a8020686f9c49a8dd1418166526f9db87fe86c2e076d36077
diff --git a/dev-perl/Perlbal/Perlbal-1.800.0-r1.ebuild b/dev-perl/Perlbal/Perlbal-1.800.0-r1.ebuild
new file mode 100644
index 000000000000..fbeb6d54b5e1
--- /dev/null
+++ b/dev-perl/Perlbal/Perlbal-1.800.0-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=DORMANDO
+MODULE_VERSION=1.80
+inherit perl-module
+
+DESCRIPTION="Reverse-proxy load balancer and webserver"
+HOMEPAGE="http://www.danga.com/perlbal/"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-perl/libwww-perl
+ dev-perl/HTTP-Date
+ dev-perl/Sys-Syscall
+ >=dev-perl/Danga-Socket-1.440.0
+ dev-perl/HTTP-Message
+ dev-perl/BSD-Resource
+ dev-perl/IO-AIO
+"
+DEPEND="${RDEPEND}"
+
+#SRC_TEST="do" # testing not available on Perlbal yet ;-)
+
+PATCHES=( "${FILESDIR}/${PN}-1.58-Use-saner-name-in-process-listing.patch" )
+
+src_install() {
+ perl-module_src_install || die "perl-module_src_install failed"
+ cd "${S}"
+ dodoc doc/*.txt
+ docinto hacking
+ dodoc doc/hacking/*.txt
+ docinto conf
+ dodoc conf/*.{dat,conf}
+ keepdir /etc/perlbal
+ newinitd "${FILESDIR}"/perlbal_init.d_1.58 perlbal
+ newconfd "${FILESDIR}"/perlbal_conf.d_1.58 perlbal
+}
+
+pkg_postinst() {
+ einfo "Please see the example configuration files located"
+ einfo "within /usr/share/doc/${PF}/conf/"
+}
diff --git a/dev-perl/Perlbal/files/Perlbal-1.58-Use-saner-name-in-process-listing.patch b/dev-perl/Perlbal/files/Perlbal-1.58-Use-saner-name-in-process-listing.patch
new file mode 100644
index 000000000000..1ccafb9cb9b7
--- /dev/null
+++ b/dev-perl/Perlbal/files/Perlbal-1.58-Use-saner-name-in-process-listing.patch
@@ -0,0 +1,34 @@
+From 75b0930eb392c6389f6e96b0c1df067ae917b962 Mon Sep 17 00:00:00 2001
+From: Robin H. Johnson <robbat2@gentoo.org>
+Date: Sat, 12 May 2007 21:32:53 -0700
+Subject: [PATCH perlbal] Use saner name in process listing.
+
+Normally the binary will turn up in the process list as:
+/usr/bin/perl $SCRIPTNAME
+
+By adding a single line, we can make it be simply '$SCRIPTNAME'.
+This makes writing init.d scripts signficently easier.
+
+Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
+---
+ perlbal | 4 ++++
+ 1 files changed, 4 insertions(+), 0 deletions(-)
+
+diff --git a/perlbal b/perlbal
+index f0149b3..7a9d28c 100755
+--- a/perlbal
++++ b/perlbal
+@@ -37,6 +37,10 @@ my $opt_daemonize;
+ my $opt_config;
+ my $opt_help;
+ my $opt_version;
++
++# Rename binary in process list to make init scripts saner
++$0 = $_ = $0;
++
+ usage(1) unless
+ Getopt::Long::GetOptions(
+ 'daemon' => \$opt_daemonize,
+--
+1.5.1.4
+
diff --git a/dev-perl/Perlbal/files/perlbal_conf.d_1.58 b/dev-perl/Perlbal/files/perlbal_conf.d_1.58
new file mode 100644
index 000000000000..626e50bfa56b
--- /dev/null
+++ b/dev-perl/Perlbal/files/perlbal_conf.d_1.58
@@ -0,0 +1,5 @@
+# $Id$
+# PIDFILE is not yet used, pending upstream still
+#PIDFILE="/var/run/perlbal.pid"
+PERLBAL_OPTS="--daemon --config=/etc/perlbal/perlbal.conf"
+# vim: ft=gentoo-conf-d:
diff --git a/dev-perl/Perlbal/files/perlbal_init.d_1.58 b/dev-perl/Perlbal/files/perlbal_init.d_1.58
new file mode 100755
index 000000000000..13d01bc1de27
--- /dev/null
+++ b/dev-perl/Perlbal/files/perlbal_init.d_1.58
@@ -0,0 +1,25 @@
+#!/sbin/runscript
+# $Id$
+
+NAME="perlbal"
+BINARY="/usr/bin/perlbal"
+
+depend() {
+ use net
+}
+
+start() {
+ ebegin "Starting $NAME"
+ # Add --pidfile when upstream supports PIDFILES
+ start-stop-daemon --start \
+ --exec ${BINARY} -- ${PERLBAL_OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping $NAME"
+ start-stop-daemon --stop --exec "${BINARY}"
+ eend $?
+}
+
+# vim: ft=gentoo-init-d:
diff --git a/dev-perl/Perlbal/metadata.xml b/dev-perl/Perlbal/metadata.xml
new file mode 100644
index 000000000000..e368a4c4c2df
--- /dev/null
+++ b/dev-perl/Perlbal/metadata.xml
@@ -0,0 +1,63 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <maintainer>
+ <email>robbat2@gentoo.org</email>
+ <description>Primary Maintainer</description>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">Perlbal</remote-id>
+ <remote-id type="cpan-module">PalImg</remote-id>
+ <remote-id type="cpan-module">PaletteModify</remote-id>
+ <remote-id type="cpan-module">Perlbal</remote-id>
+ <remote-id type="cpan-module">Perlbal::AIO</remote-id>
+ <remote-id type="cpan-module">Perlbal::BackendHTTP</remote-id>
+ <remote-id type="cpan-module">Perlbal::Cache</remote-id>
+ <remote-id type="cpan-module">Perlbal::ChunkedUploadState</remote-id>
+ <remote-id type="cpan-module">Perlbal::ClientHTTP</remote-id>
+ <remote-id type="cpan-module">Perlbal::ClientHTTPBase</remote-id>
+ <remote-id type="cpan-module">Perlbal::ClientManage</remote-id>
+ <remote-id type="cpan-module">Perlbal::ClientProxy</remote-id>
+ <remote-id type="cpan-module">Perlbal::CommandContext</remote-id>
+ <remote-id type="cpan-module">Perlbal::Fields</remote-id>
+ <remote-id type="cpan-module">Perlbal::HTTPHeaders</remote-id>
+ <remote-id type="cpan-module">Perlbal::ManageCommand</remote-id>
+ <remote-id type="cpan-module">Perlbal::Plugin::AccessControl</remote-id>
+ <remote-id type="cpan-module">Perlbal::Plugin::AutoRemoveLeadingDir</remote-id>
+ <remote-id type="cpan-module">Perlbal::Plugin::Cgilike</remote-id>
+ <remote-id type="cpan-module">Perlbal::Plugin::Cgilike::Request</remote-id>
+ <remote-id type="cpan-module">Perlbal::Plugin::EchoService</remote-id>
+ <remote-id type="cpan-module">Perlbal::Plugin::EchoService::Client</remote-id>
+ <remote-id type="cpan-module">Perlbal::Plugin::FlvStreaming</remote-id>
+ <remote-id type="cpan-module">Perlbal::Plugin::Highpri</remote-id>
+ <remote-id type="cpan-module">Perlbal::Plugin::Include</remote-id>
+ <remote-id type="cpan-module">Perlbal::Plugin::LazyCDN</remote-id>
+ <remote-id type="cpan-module">Perlbal::Plugin::MaxContentLength</remote-id>
+ <remote-id type="cpan-module">Perlbal::Plugin::NotModified</remote-id>
+ <remote-id type="cpan-module">Perlbal::Plugin::Palimg</remote-id>
+ <remote-id type="cpan-module">Perlbal::Plugin::Queues</remote-id>
+ <remote-id type="cpan-module">Perlbal::Plugin::Redirect</remote-id>
+ <remote-id type="cpan-module">Perlbal::Plugin::Stats</remote-id>
+ <remote-id type="cpan-module">Perlbal::Plugin::Stats::Storage</remote-id>
+ <remote-id type="cpan-module">Perlbal::Plugin::Throttle</remote-id>
+ <remote-id type="cpan-module">Perlbal::Plugin::Throttle::Store</remote-id>
+ <remote-id type="cpan-module">Perlbal::Plugin::Throttle::Store::Memcached</remote-id>
+ <remote-id type="cpan-module">Perlbal::Plugin::Throttle::Store::Memory</remote-id>
+ <remote-id type="cpan-module">Perlbal::Plugin::Vhosts</remote-id>
+ <remote-id type="cpan-module">Perlbal::Plugin::Vpaths</remote-id>
+ <remote-id type="cpan-module">Perlbal::Plugin::XFFExtras</remote-id>
+ <remote-id type="cpan-module">Perlbal::Pool</remote-id>
+ <remote-id type="cpan-module">Perlbal::ReproxyManager</remote-id>
+ <remote-id type="cpan-module">Perlbal::Service</remote-id>
+ <remote-id type="cpan-module">Perlbal::Socket</remote-id>
+ <remote-id type="cpan-module">Perlbal::SocketSSL</remote-id>
+ <remote-id type="cpan-module">Perlbal::SocketSSL2</remote-id>
+ <remote-id type="cpan-module">Perlbal::TCPListener</remote-id>
+ <remote-id type="cpan-module">Perlbal::Test</remote-id>
+ <remote-id type="cpan-module">Perlbal::Test::WebClient</remote-id>
+ <remote-id type="cpan-module">Perlbal::Test::WebServer</remote-id>
+ <remote-id type="cpan-module">Perlbal::UploadListener</remote-id>
+ <remote-id type="cpan-module">Perlbal::Util</remote-id>
+ </upstream>
+</pkgmetadata>