summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-08-02 23:08:14 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-08-02 23:14:56 +0200
commit6dd3848d4ed7c18a49f29c3d4f010e3e670cfd71 (patch)
tree66c5a2d9d69aaa86b66ccaadb241a3d9b8601856 /dev-perl/Quota
parentdev-perl/prefork: Version bump 1.05 (diff)
downloadgentoo-6dd3848d4ed7c18a49f29c3d4f010e3e670cfd71.tar.gz
gentoo-6dd3848d4ed7c18a49f29c3d4f010e3e670cfd71.tar.bz2
gentoo-6dd3848d4ed7c18a49f29c3d4f010e3e670cfd71.zip
dev-perl/Quota: Version bump 1.8.1
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'dev-perl/Quota')
-rw-r--r--dev-perl/Quota/Manifest1
-rw-r--r--dev-perl/Quota/Quota-1.8.1.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-perl/Quota/Manifest b/dev-perl/Quota/Manifest
index cf9c0f6e79ce..ef8d579cf4c3 100644
--- a/dev-perl/Quota/Manifest
+++ b/dev-perl/Quota/Manifest
@@ -1 +1,2 @@
DIST Quota-1.7.2.tar.gz 50436 BLAKE2B 6a90e545fcb3739f4f10cbe5caed7ba5a3542c19a8f1b68baeefc12dab77ac27d125e3de083c1cf6d68c29fe126c8e4f2eaddaa1c55c1974de0e0451011f6c7c SHA512 55ea9fbf027676b0e6f7a6f97fd3e75749860ebefe0127791a0d8cd8a427676eb1f6bf1ddf1a3687666752430faef877eedd12ccce39b7b76466fc7bfc628433
+DIST Quota-1.8.1.tar.gz 57058 BLAKE2B 9f34d11896e6a8660f8777b5d6d6405d53619936aef2a17af58cf3e024f936b278fe14e055a685508c6cef9d07b56eab0712f6745e53c9fdb99d6bd97e864435 SHA512 9e27cb03c7cd76a995ff775b9a5a67b8d8deeb814efacb17b4769c567935ebabe03ba2354a6977ae86fffaeb65e8f457906adee60de3e0a86ba78516057c1d72
diff --git a/dev-perl/Quota/Quota-1.8.1.ebuild b/dev-perl/Quota/Quota-1.8.1.ebuild
new file mode 100644
index 000000000000..7b2014f2a3ea
--- /dev/null
+++ b/dev-perl/Quota/Quota-1.8.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=TOMZO
+inherit perl-module toolchain-funcs flag-o-matic
+
+DESCRIPTION="Perl interface to file system quotas"
+
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ sys-fs/quota[rpc]
+ net-libs/libtirpc
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ virtual/pkgconfig
+"
+
+# Tests need real FS access/root permissions and are interactive
+DIST_TEST=skip
+
+src_prepare() {
+ default
+ DIST_MAKE=(
+ "INC=$($(tc-getPKG_CONFIG) --cflags libtirpc)"
+ "OTHERLDFLAGS=$($(tc-getPKG_CONFIG) --libs libtirpc)"
+ )
+
+ # disable AFS completely for now, need somebody who can really test it
+ sed -i -e 's|-d "/afs"|0|' Makefile.PL || die "sed failed"
+}
+
+src_test() {
+ ebegin "Compile testing Quota ${PV}"
+ perl -Mblib="${S}" -M"Quota ${PV} ()" -e1
+ if ! eend $?; then
+ echo
+ eerror "One or more modules failed compile:";
+ eerror " Quota ${PV}"
+ die "Failing due to module compilation errors";
+ fi
+ perl-module_src_test
+}