summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2018-01-09 14:31:09 +1300
committerKent Fredric <kentnl@gentoo.org>2018-01-09 14:32:26 +1300
commit3ee1b22ff223718192ea38e1ffce07997a2eb733 (patch)
treeb4492e4dc091426575b5d5a292c557817d91d1a4 /dev-perl/Specio/Specio-0.420.0.ebuild
parentmedia-gfx/converseen: Drop old (diff)
downloadgentoo-3ee1b22ff223718192ea38e1ffce07997a2eb733.tar.gz
gentoo-3ee1b22ff223718192ea38e1ffce07997a2eb733.tar.bz2
gentoo-3ee1b22ff223718192ea38e1ffce07997a2eb733.zip
dev-perl/Specio: Bump to version 0.420.0
Upstream: - Check for overloading without overload::Overloaded - Fix many bugs in type assertion functions avoiding exceptions in type-checks - Improved failure descriptions for type constraints - Support for creating anonymous type assertion exports - Fix subification overloading - Fix checking for class loaded w/ Perl 5.28 optimizations - Fix name of {Lax,Strict}VersionStr functions as per documented Keywording: - New dependencies, dropped: alpha arm64 ia64 ppc64 sparc Package-Manager: Portage-2.3.18, Repoman-2.3.6
Diffstat (limited to 'dev-perl/Specio/Specio-0.420.0.ebuild')
-rw-r--r--dev-perl/Specio/Specio-0.420.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-perl/Specio/Specio-0.420.0.ebuild b/dev-perl/Specio/Specio-0.420.0.ebuild
new file mode 100644
index 000000000000..6f902d5e17d5
--- /dev/null
+++ b/dev-perl/Specio/Specio-0.420.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=DROLSKY
+DIST_VERSION=0.42
+inherit perl-module
+
+DESCRIPTION="Type constraints and coercions for Perl"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~x86"
+IUSE="test minimal"
+
+RDEPEND="
+ !minimal? ( >=dev-perl/Ref-Util-0.112.0 )
+ virtual/perl-Carp
+ dev-perl/Devel-StackTrace
+ dev-perl/Eval-Closure
+ virtual/perl-Exporter
+ virtual/perl-IO
+ dev-perl/MRO-Compat
+ dev-perl/Module-Runtime
+ >=dev-perl/Role-Tiny-1.3.3
+ >=virtual/perl-Scalar-List-Utils-1.330.0
+ virtual/perl-Storable
+ dev-perl/Sub-Quote
+ dev-perl/Test-Fatal
+ >=virtual/perl-Test-Simple-0.960.0
+ dev-perl/Try-Tiny
+ virtual/perl-parent
+ >=virtual/perl-version-0.830.0
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-File-Spec
+ dev-perl/Test-Needs
+ )
+"
+mydoc="TODO.md"