summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2018-03-06 16:38:09 +1300
committerKent Fredric <kentnl@gentoo.org>2018-03-06 16:38:55 +1300
commitca17b171c7400b64090a9489ada32683bb63674b (patch)
tree67a6377d7532fc85f739c49e468c6ca1748722bc /dev-perl/Test-MockModule/Test-MockModule-0.130.0.ebuild
parentx11-drivers/xf86-video-intel: Add live ebuild (diff)
downloadgentoo-ca17b171c7400b64090a9489ada32683bb63674b.tar.gz
gentoo-ca17b171c7400b64090a9489ada32683bb63674b.tar.bz2
gentoo-ca17b171c7400b64090a9489ada32683bb63674b.zip
dev-perl/Test-MockModule: Bump to version 0.130.0
Upstream: - Add noop() function - Add redefine() function Package-Manager: Portage-2.3.18, Repoman-2.3.6
Diffstat (limited to 'dev-perl/Test-MockModule/Test-MockModule-0.130.0.ebuild')
-rw-r--r--dev-perl/Test-MockModule/Test-MockModule-0.130.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-perl/Test-MockModule/Test-MockModule-0.130.0.ebuild b/dev-perl/Test-MockModule/Test-MockModule-0.130.0.ebuild
new file mode 100644
index 000000000000..4cf173bb4fa6
--- /dev/null
+++ b/dev-perl/Test-MockModule/Test-MockModule-0.130.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_VERSION=0.13
+DIST_AUTHOR=GFRANKS
+inherit perl-module
+
+DESCRIPTION="Override subroutines in a module for unit testing"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Carp
+ dev-perl/SUPER
+ virtual/perl-Scalar-List-Utils
+"
+DEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-0.380.0
+ test? ( >=virtual/perl-Test-Simple-0.880.0 )
+"
+PERL_RM_FILES=( "t/pod_coverage.t" "t/pod.t" )