summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-05-30 18:33:33 +1200
committerKent Fredric <kentnl@gentoo.org>2017-05-30 18:33:45 +1200
commit1bc7dc561828fcdd7f5a2a82739b05fffdd03e83 (patch)
tree74760aa477cf740d03ae61fd5187c4779df5ad67 /dev-perl/Text-CSV_XS/Text-CSV_XS-1.290.0.ebuild
parentdev-perl/Text-CSV: Bump to version 1.950.0 (diff)
downloadgentoo-1bc7dc561828fcdd7f5a2a82739b05fffdd03e83.tar.gz
gentoo-1bc7dc561828fcdd7f5a2a82739b05fffdd03e83.tar.bz2
gentoo-1bc7dc561828fcdd7f5a2a82739b05fffdd03e83.zip
dev-perl/Text-CSV_XS: Bump to version 1.290.0
Upstream: - Add strict attribute support Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-perl/Text-CSV_XS/Text-CSV_XS-1.290.0.ebuild')
-rw-r--r--dev-perl/Text-CSV_XS/Text-CSV_XS-1.290.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-perl/Text-CSV_XS/Text-CSV_XS-1.290.0.ebuild b/dev-perl/Text-CSV_XS/Text-CSV_XS-1.290.0.ebuild
new file mode 100644
index 000000000000..4d1380aece4a
--- /dev/null
+++ b/dev-perl/Text-CSV_XS/Text-CSV_XS-1.290.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=HMBRAND
+DIST_A_EXT=tgz
+DIST_VERSION=1.29
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="Comma-separated values manipulation routines"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-IO
+ virtual/perl-XSLoader
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-Test-Simple
+ )
+"
+src_test() {
+ perl_rm_files "t/00_pod.t" "t/01_pod.t"
+ perl-module_src_test
+}