summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2018-03-15 21:25:09 +1300
committerKent Fredric <kentnl@gentoo.org>2018-03-15 21:25:09 +1300
commit47c2985cf470b4bb8adb319900ae26da3c09468e (patch)
treec7c27b4a03e5a9ba94411c34f8b8320c252f03d2 /dev-perl/Text-Kakasi
parentdev-perl/Text-Iconv: EAPI6 + tests (diff)
downloadgentoo-47c2985cf470b4bb8adb319900ae26da3c09468e.tar.gz
gentoo-47c2985cf470b4bb8adb319900ae26da3c09468e.tar.bz2
gentoo-47c2985cf470b4bb8adb319900ae26da3c09468e.zip
dev-perl/Text-Kakasi: EAPI6 + tests
- EAPI6ify - gitify patches - Enable tests Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-perl/Text-Kakasi')
-rw-r--r--dev-perl/Text-Kakasi/Text-Kakasi-2.40.0-r2.ebuild20
-rw-r--r--dev-perl/Text-Kakasi/files/Text-Kakasi-2.04-makefile.patch26
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-perl/Text-Kakasi/Text-Kakasi-2.40.0-r2.ebuild b/dev-perl/Text-Kakasi/Text-Kakasi-2.40.0-r2.ebuild
new file mode 100644
index 000000000000..e34245db58a9
--- /dev/null
+++ b/dev-perl/Text-Kakasi/Text-Kakasi-2.40.0-r2.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=DANKOGAI
+DIST_VERSION=2.04
+inherit perl-module
+
+DESCRIPTION="This module provides libkakasi interface for Perl"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
+IUSE=""
+
+RDEPEND=">=app-i18n/kakasi-2.3.4"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${PN}-2.04-makefile.patch )
diff --git a/dev-perl/Text-Kakasi/files/Text-Kakasi-2.04-makefile.patch b/dev-perl/Text-Kakasi/files/Text-Kakasi-2.04-makefile.patch
new file mode 100644
index 000000000000..118d924ea4fd
--- /dev/null
+++ b/dev-perl/Text-Kakasi/files/Text-Kakasi-2.04-makefile.patch
@@ -0,0 +1,26 @@
+From 9d7a18a0491638944b64b69b0f9244a6eb98f6c4 Mon Sep 17 00:00:00 2001
+From: Yamakura Makoto <yakina@gentoo.org>
+Date: Thu, 18 Sep 2003 13:12:14 +1200
+Subject: Fix Makefile.PL for system inc/lib paths
+
+---
+ Makefile.PL | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/Makefile.PL b/Makefile.PL
+index 6640058..513dabc 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -6,7 +6,7 @@ use ExtUtils::MakeMaker;
+ WriteMakefile(
+ 'NAME' => 'Text::Kakasi',
+ 'VERSION_FROM' => 'Kakasi.pm',
+- 'INC' => '-I/usr/local/include',
+- 'LIBS' => ['-L/usr/local/lib -lkakasi'],
++ 'INC' => '-I/usr/include',
++ 'LIBS' => ['-L/usr/lib -lkakasi'],
+ 'DEFINE' => '-DWAKATIGAKI',
+ );
+--
+2.16.2
+