summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2018-03-14 16:43:59 +1300
committerKent Fredric <kentnl@gentoo.org>2018-03-14 16:43:59 +1300
commit2754ba0984a6e813911f09af933d22454c8aa521 (patch)
treed0c49fbc8bd37303465fc08816b7bc9e9ff0c9e9 /dev-perl/Try-Tiny/Try-Tiny-0.300.0.ebuild
parentdev-perl/Tree-Simple: Bump to version 1.330.0 (diff)
downloadgentoo-2754ba0984a6e813911f09af933d22454c8aa521.tar.gz
gentoo-2754ba0984a6e813911f09af933d22454c8aa521.tar.bz2
gentoo-2754ba0984a6e813911f09af933d22454c8aa521.zip
dev-perl/Try-Tiny: Bump to version 0.300.0
Upstream: - 'finally' blocks are now run for all methods of leaving try block, including exit and goto - Resolve pseudofork induced segfaults on windows by storing finalizers in a hash instead of an array - Guard given/when tests against perl 5.27 release changes Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-perl/Try-Tiny/Try-Tiny-0.300.0.ebuild')
-rw-r--r--dev-perl/Try-Tiny/Try-Tiny-0.300.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-perl/Try-Tiny/Try-Tiny-0.300.0.ebuild b/dev-perl/Try-Tiny/Try-Tiny-0.300.0.ebuild
new file mode 100644
index 000000000000..6e04d125e62b
--- /dev/null
+++ b/dev-perl/Try-Tiny/Try-Tiny-0.300.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=ETHER
+DIST_VERSION=0.30
+inherit perl-module
+
+DESCRIPTION="Minimal try/catch with proper localization of \$@"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test minimal"
+
+RDEPEND="
+ !<=dev-perl/Try-Tiny-Except-0.10.0
+ !minimal? (
+ || ( >=virtual/perl-Scalar-List-Utils-1.400.0 dev-perl/Sub-Name )
+ )
+ virtual/perl-Carp
+ >=virtual/perl-Exporter-5.570.0
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ !minimal? (
+ >=virtual/perl-CPAN-Meta-2.120.900
+ >=dev-perl/Capture-Tiny-0.120.0
+ )
+ virtual/perl-File-Spec
+ virtual/perl-Test-Simple
+ virtual/perl-if
+ )
+"