summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2018-03-14 18:20:29 +1300
committerKent Fredric <kentnl@gentoo.org>2018-03-14 19:15:52 +1300
commitc98e19ef3d2a844cac6d896666cb85e6576ce1b9 (patch)
tree5c52c740e77e0adab65a07795704c32f82f58c77 /dev-perl/Type-Tiny/Type-Tiny-1.2.1.ebuild
parentdev-util/ccache: add ~arm, bug #643082 (diff)
downloadgentoo-c98e19ef3d2a844cac6d896666cb85e6576ce1b9.tar.gz
gentoo-c98e19ef3d2a844cac6d896666cb85e6576ce1b9.tar.bz2
gentoo-c98e19ef3d2a844cac6d896666cb85e6576ce1b9.zip
dev-perl/Type-Tiny: Bump to version 1.2.1
Upstream: - Disable broken tests against old moose - Recommend older (and existing) version of Ref::Util::XS Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-perl/Type-Tiny/Type-Tiny-1.2.1.ebuild')
-rw-r--r--dev-perl/Type-Tiny/Type-Tiny-1.2.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-perl/Type-Tiny/Type-Tiny-1.2.1.ebuild b/dev-perl/Type-Tiny/Type-Tiny-1.2.1.ebuild
new file mode 100644
index 000000000000..86f1513e9bd7
--- /dev/null
+++ b/dev-perl/Type-Tiny/Type-Tiny-1.2.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=TOBYINK
+DIST_VERSION=1.002001
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="tiny, yet Moo(se)-compatible type constraint"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="test minimal"
+
+# Test rdep for Test::TypeTiny
+RDEPEND="
+ !<dev-perl/Kavorka-0.13.0
+ !<dev-perl/Types-ReadOnly-0.1.0
+ >=dev-perl/Exporter-Tiny-0.26.0
+ >=virtual/perl-Test-Simple-1.1.10
+ !minimal? (
+ >=dev-perl/Devel-LexAlias-0.50.0
+ dev-perl/Devel-StackTrace
+ >=dev-perl/Ref-Util-XS-0.100.0
+ >=dev-perl/Regexp-Util-0.3.0
+ virtual/perl-Scalar-List-Utils
+ dev-perl/Type-Tie
+ >=dev-perl/Type-Tiny-XS-0.11.0
+ )
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.170.0
+ >=virtual/perl-CPAN-Meta-Requirements-2.0.0
+ test? (
+ dev-perl/Test-Warnings
+ )
+"