summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-06-10 18:02:12 +0000
committerSam James <sam@gentoo.org>2021-06-10 18:02:12 +0000
commit6c5aa33b36a46d5d3a3fc46e1dbf7ce62861e2e4 (patch)
tree3b365b9f5bea694b0451245c5ea1391a53291054 /dev-perl/URI-Fetch
parentnet-analyzer/tcpdump: re-enable tests in 4.99.1 (diff)
downloadgentoo-6c5aa33b36a46d5d3a3fc46e1dbf7ce62861e2e4.tar.gz
gentoo-6c5aa33b36a46d5d3a3fc46e1dbf7ce62861e2e4.tar.bz2
gentoo-6c5aa33b36a46d5d3a3fc46e1dbf7ce62861e2e4.zip
dev-perl/URI-Fetch: apply upstream patch for Perl minimum version
Closes: https://bugs.gentoo.org/794676 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-perl/URI-Fetch')
-rw-r--r--dev-perl/URI-Fetch/URI-Fetch-0.130.0.ebuild6
-rw-r--r--dev-perl/URI-Fetch/files/URI-Fetch-0.130.0-min-perl.patch12
2 files changed, 17 insertions, 1 deletions
diff --git a/dev-perl/URI-Fetch/URI-Fetch-0.130.0.ebuild b/dev-perl/URI-Fetch/URI-Fetch-0.130.0.ebuild
index 532f71df28f9..02383629c002 100644
--- a/dev-perl/URI-Fetch/URI-Fetch-0.130.0.ebuild
+++ b/dev-perl/URI-Fetch/URI-Fetch-0.130.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -29,3 +29,7 @@ DEPEND="${RDEPEND}
>=dev-perl/Test-RequiresInternet-0.50.0
)
"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-min-perl.patch
+)
diff --git a/dev-perl/URI-Fetch/files/URI-Fetch-0.130.0-min-perl.patch b/dev-perl/URI-Fetch/files/URI-Fetch-0.130.0-min-perl.patch
new file mode 100644
index 000000000000..3108055dd543
--- /dev/null
+++ b/dev-perl/URI-Fetch/files/URI-Fetch-0.130.0-min-perl.patch
@@ -0,0 +1,12 @@
+https://github.com/neilb/URI-Fetch/commit/20eba82783a5c08adc88ff1cdc7ee9433d63ae4f.patch
+https://bugs.gentoo.org/794676
+--- a/lib/URI/Fetch.pm
++++ b/lib/URI/Fetch.pm
+@@ -1,6 +1,6 @@
+ package URI::Fetch;
+ $URI::Fetch::VERSION = '0.13';
+-use 5.008_001;
++use 5.008001;
+ use strict;
+ use warnings;
+