summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2018-03-28 15:58:48 +1300
committerKent Fredric <kentnl@gentoo.org>2018-03-28 15:58:48 +1300
commit3dbf778d8eb6f2e52d3dd0015ea5a56a619b2915 (patch)
tree5df2e1826409d0f17303a7708fe715ab9be7f7d8 /dev-perl/XML-Compile/XML-Compile-1.600.0.ebuild
parentdev-perl/XML-CompactTree-XS: Bump to version 0.30.0 (diff)
downloadgentoo-3dbf778d8eb6f2e52d3dd0015ea5a56a619b2915.tar.gz
gentoo-3dbf778d8eb6f2e52d3dd0015ea5a56a619b2915.tar.bz2
gentoo-3dbf778d8eb6f2e52d3dd0015ea5a56a619b2915.zip
dev-perl/XML-Compile: Bump to version 1.600.0
Upstream: - Improve seperation of lexical-space and value-space facets - Fix json_friendly enumeration and pattern facets - Fix early facet on missing field - Require newer Log::Report - Move json regression tests to being author tests - Accept non-ascii word characters in NCName type - use facets with nested simpletypes Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-perl/XML-Compile/XML-Compile-1.600.0.ebuild')
-rw-r--r--dev-perl/XML-Compile/XML-Compile-1.600.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-perl/XML-Compile/XML-Compile-1.600.0.ebuild b/dev-perl/XML-Compile/XML-Compile-1.600.0.ebuild
new file mode 100644
index 000000000000..a4b3b79c2a94
--- /dev/null
+++ b/dev-perl/XML-Compile/XML-Compile-1.600.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=MARKOV
+DIST_VERSION=1.60
+inherit perl-module
+
+DESCRIPTION="Compilation based XML Processing"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=virtual/perl-Digest-MD5-2.360.0
+ >=dev-perl/Log-Report-1.200.0
+ >=virtual/perl-MIME-Base64-3.100.0
+ >=virtual/perl-Math-BigInt-1.770.0
+ >=virtual/perl-Math-BigRat-0.100.0
+ dev-perl/Types-Serialiser
+ virtual/perl-Scalar-List-Utils
+ >=dev-perl/XML-LibXML-2.10.700
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=dev-perl/Test-Deep-0.95.0
+ >=virtual/perl-Test-Simple-0.540.0
+ >=dev-perl/XML-Compile-Tester-0.900.0
+ )
+"
+src_install() {
+ perl-module_src_install
+ dodoc -r html
+}