summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-12-14 06:21:46 +0000
committerSam James <sam@gentoo.org>2021-12-14 06:21:46 +0000
commitdb40847290102119b36c3d2fe379f01267cda109 (patch)
tree7e7d4bddbd5812aab86ce11e17f517eafa7fbca7 /dev-perl/XML-Parser/XML-Parser-2.440.0.ebuild
parentmount-boot.eclass: support EAPI 8 (diff)
downloadgentoo-db40847290102119b36c3d2fe379f01267cda109.tar.gz
gentoo-db40847290102119b36c3d2fe379f01267cda109.tar.bz2
gentoo-db40847290102119b36c3d2fe379f01267cda109.zip
dev-perl/XML-Parser: restore 2.440.0
This reverts commit d9e7940f92101dfc97efd94d6c60a45a17c4c234. Let users downgrade / mask a newer version if they want to for now while we investigate issues with the newer version. Bug: https://bugs.gentoo.org/827966 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-perl/XML-Parser/XML-Parser-2.440.0.ebuild')
-rw-r--r--dev-perl/XML-Parser/XML-Parser-2.440.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-perl/XML-Parser/XML-Parser-2.440.0.ebuild b/dev-perl/XML-Parser/XML-Parser-2.440.0.ebuild
new file mode 100644
index 000000000000..744eee96e008
--- /dev/null
+++ b/dev-perl/XML-Parser/XML-Parser-2.440.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MODULE_AUTHOR=TODDR
+MODULE_VERSION=2.44
+inherit perl-module multilib
+
+DESCRIPTION="A Perl extension interface to James Clark's XML parser, expat"
+
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND=">=dev-libs/expat-1.95.1-r1"
+DEPEND="${RDEPEND}"
+
+SRC_TEST=do
+
+src_configure() {
+ myconf="EXPATLIBPATH=${EPREFIX}/usr/$(get_libdir) EXPATINCPATH=${EPREFIX}/usr/include"
+ perl-module_src_configure
+}