summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2018-03-28 14:15:10 +1300
committerKent Fredric <kentnl@gentoo.org>2018-03-28 14:16:06 +1300
commit176344a770952235f2229bbd28a8078cbb9c3393 (patch)
treec221bcc7706ce7a4f548a92cbf9a581c25b206f3 /dev-perl/XML-Simple/XML-Simple-2.250.0.ebuild
parentsys-auth/sssd-1.13.1: added ~mips, bug 540540 (diff)
downloadgentoo-176344a770952235f2229bbd28a8078cbb9c3393.tar.gz
gentoo-176344a770952235f2229bbd28a8078cbb9c3393.tar.bz2
gentoo-176344a770952235f2229bbd28a8078cbb9c3393.zip
dev-perl/XML-Simple: Bump to version 2.250.0
- Fix tests failing with XML::LibXML::SAX ( #625538 ) - Purge author tests Upstream: - Improve circular reference detection - Don't initialise PREFERRED_PARSER to undef during load - Disable entity expansion when using XML::Parser - Call to XML::Parser constructor now in isolated method for subclass overriding Bug: https://bugs.gentoo.org/625538 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-perl/XML-Simple/XML-Simple-2.250.0.ebuild')
-rw-r--r--dev-perl/XML-Simple/XML-Simple-2.250.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-perl/XML-Simple/XML-Simple-2.250.0.ebuild b/dev-perl/XML-Simple/XML-Simple-2.250.0.ebuild
new file mode 100644
index 000000000000..44f22539e97c
--- /dev/null
+++ b/dev-perl/XML-Simple/XML-Simple-2.250.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=GRANTM
+DIST_VERSION=2.25
+inherit perl-module
+
+DESCRIPTION="An API for simple XML files"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Storable
+ >=dev-perl/XML-NamespaceSupport-1.40.0
+ >=dev-perl/XML-SAX-0.150.0
+ dev-perl/XML-SAX-Expat
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( >=virtual/perl-Test-Simple-0.880.0 )
+"
+PATCHES=("${FILESDIR}/${PN}-2.25-saxtests.patch")
+PERL_RM_FILES=("t/author-pod-syntax.t")