summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/crypt-rsa/crypt-rsa-1.990.0-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/crypt-rsa/crypt-rsa-1.990.0-r1.ebuild')
-rw-r--r--dev-perl/crypt-rsa/crypt-rsa-1.990.0-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-perl/crypt-rsa/crypt-rsa-1.990.0-r1.ebuild b/dev-perl/crypt-rsa/crypt-rsa-1.990.0-r1.ebuild
new file mode 100644
index 000000000000..fe23907e0a90
--- /dev/null
+++ b/dev-perl/crypt-rsa/crypt-rsa-1.990.0-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_PN=Crypt-RSA
+MODULE_AUTHOR=VIPUL
+MODULE_VERSION=1.99
+inherit perl-module
+
+DESCRIPTION="RSA public-key cryptosystem"
+
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ~mips ~ppc x86 ~x86-solaris"
+IUSE=""
+
+DEPEND="dev-perl/class-loader
+ dev-perl/Crypt-Blowfish
+ dev-perl/convert-ascii-armour
+ dev-perl/crypt-cbc
+ dev-perl/crypt-primes
+ dev-perl/crypt-random
+ dev-perl/data-buffer
+ dev-perl/digest-md2
+ virtual/perl-Digest-MD5
+ dev-perl/Digest-SHA1
+ >=dev-perl/math-pari-2.010603
+ dev-perl/Sort-Versions
+ dev-perl/tie-encryptedhash"
+RDEPEND="${DEPEND}"
+
+SRC_TEST="do"