summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/gnome2-perl
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/gnome2-perl')
-rw-r--r--dev-perl/gnome2-perl/Manifest2
-rw-r--r--dev-perl/gnome2-perl/gnome2-perl-1.42.0-r1.ebuild31
-rw-r--r--dev-perl/gnome2-perl/gnome2-perl-1.45.0.ebuild31
-rw-r--r--dev-perl/gnome2-perl/metadata.xml9
4 files changed, 73 insertions, 0 deletions
diff --git a/dev-perl/gnome2-perl/Manifest b/dev-perl/gnome2-perl/Manifest
new file mode 100644
index 000000000000..adf0a150221e
--- /dev/null
+++ b/dev-perl/gnome2-perl/Manifest
@@ -0,0 +1,2 @@
+DIST Gnome2-1.042.tar.gz 80062 SHA256 f4a183bf17ae8de5e27bb9b98e14cd3e960cf6a194e54a712c5783700b37c379 SHA512 0d3b2995ba0542dd4b0eee9eec10dfb3de9259ec3d8d1002bd90bdff71372766ac6fdb67819bb1db42e0340e3cca46c38e5cbaf10844ebeb582131a59abac544 WHIRLPOOL 4668e8fb07b4e140da12e4c6ae19af43f16785fdde345f8c70820e4ade178608b3f48c9fcd19b0cd7e59ddc5f85d3541a80b2c93002117468bad40b8b14479bd
+DIST Gnome2-1.045.tar.gz 79262 SHA256 1426044de3ab4900e0a7cb0cc27aa2213c6ad29ed0676b018dce2eee832692f7 SHA512 fa4ac02dbc3d96e6790cff964968f86b9eaf5bb79bbdd2fb3e967e4e8f4bcad25bf1308d25b26ae0298303dfaab7aaa5b49028336d25648614208e622a848316 WHIRLPOOL 54d747c44d06fa7324f3234d9849e400dedd9a0dbfff35834ad754bc74638df83dafd3dca5dab6de13832c533fdd19186765e301d004a03951f4cfad8be2ba6d
diff --git a/dev-perl/gnome2-perl/gnome2-perl-1.42.0-r1.ebuild b/dev-perl/gnome2-perl/gnome2-perl-1.42.0-r1.ebuild
new file mode 100644
index 000000000000..7c41c07b58d1
--- /dev/null
+++ b/dev-perl/gnome2-perl/gnome2-perl-1.42.0-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_PN=Gnome2
+MODULE_AUTHOR=TSCH
+MODULE_VERSION=1.042
+inherit perl-module
+
+DESCRIPTION="Perl interface to the 2.x series of the Gnome libraries"
+HOMEPAGE="http://gtk2-perl.sourceforge.net/ ${HOMEPAGE}"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 ~ppc x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2
+ >=dev-perl/gtk2-perl-1.0.0
+ gnome-base/libgnomeui
+ gnome-base/libbonoboui
+ >=dev-perl/gnome2-canvas-1.0.0
+ >=dev-perl/glib-perl-1.40.0
+ >=dev-perl/gnome2-vfs-perl-1.0.0"
+DEPEND="${RDEPEND}
+ dev-perl/ExtUtils-Depends
+ dev-perl/extutils-pkgconfig"
+
+SRC_TEST=do
diff --git a/dev-perl/gnome2-perl/gnome2-perl-1.45.0.ebuild b/dev-perl/gnome2-perl/gnome2-perl-1.45.0.ebuild
new file mode 100644
index 000000000000..98b589fe790d
--- /dev/null
+++ b/dev-perl/gnome2-perl/gnome2-perl-1.45.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_PN=Gnome2
+MODULE_AUTHOR=XAOC
+MODULE_VERSION=1.045
+inherit perl-module
+
+DESCRIPTION="Perl interface to the 2.x series of the Gnome libraries"
+HOMEPAGE="http://gtk2-perl.sourceforge.net/ ${HOMEPAGE}"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2
+ dev-perl/gtk2-perl
+ gnome-base/libgnomeui
+ gnome-base/libbonoboui
+ dev-perl/gnome2-canvas
+ >=dev-perl/glib-perl-1.40.0
+ dev-perl/gnome2-vfs-perl"
+DEPEND="${RDEPEND}
+ dev-perl/ExtUtils-Depends
+ dev-perl/extutils-pkgconfig"
+
+SRC_TEST=do
diff --git a/dev-perl/gnome2-perl/metadata.xml b/dev-perl/gnome2-perl/metadata.xml
new file mode 100644
index 000000000000..20464135e36a
--- /dev/null
+++ b/dev-perl/gnome2-perl/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Gnome2</remote-id>
+ <remote-id type="cpan-module">Gnome2</remote-id>
+ </upstream>
+</pkgmetadata>