summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-06-22 17:50:16 +1200
committerKent Fredric <kentnl@gentoo.org>2017-06-22 18:31:08 +1200
commit3dc08fd81221debd1bd60170b92222aa52769881 (patch)
tree9c3358e0e56f8bb06ca79877d716272342b16c8f /dev-perl/prefork/prefork-1.40.0-r2.ebuild
parentnet-mail/cyrus-imapd: bump to 3.0.2 (diff)
downloadgentoo-3dc08fd81221debd1bd60170b92222aa52769881.tar.gz
gentoo-3dc08fd81221debd1bd60170b92222aa52769881.tar.bz2
gentoo-3dc08fd81221debd1bd60170b92222aa52769881.zip
dev-perl/prefork: Fix broken Module::Install::DSL patching.
For some rediculous reason, this module changes everything about Perl, so optional newlines cease to be optional. Additionally, this causes configure to exit true, but fail to configure. And this breaks install time, necessitating an -r1 bump. Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-perl/prefork/prefork-1.40.0-r2.ebuild')
-rw-r--r--dev-perl/prefork/prefork-1.40.0-r2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-perl/prefork/prefork-1.40.0-r2.ebuild b/dev-perl/prefork/prefork-1.40.0-r2.ebuild
new file mode 100644
index 000000000000..ea9a4a952f0b
--- /dev/null
+++ b/dev-perl/prefork/prefork-1.40.0-r2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MODULE_AUTHOR=ADAMK
+MODULE_VERSION=1.04
+inherit perl-module
+
+DESCRIPTION="Optimized module loading for forking or non-forking processes"
+
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm arm64 hppa ia64 m68k ~mips ppc ~ppc64 s390 sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+DEPEND=">=virtual/perl-File-Spec-0.80
+ >=virtual/perl-Scalar-List-Utils-1.10"
+RDEPEND="${DEPEND}"
+
+SRC_TEST="do"
+
+src_prepare() {
+ sed -i -e 's/use inc::Module::Install::DSL /use lib q[.];\nuse inc::Module::Install::DSL /' Makefile.PL ||
+ die "Can't patch Makefile.PL for 5.26 dot-in-inc"
+ perl-module_src_prepare
+}