summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-05-23 08:07:12 +1200
committerKent Fredric <kentnl@gentoo.org>2020-05-23 08:08:42 +1200
commit19415adb30166c5821c2bb3ff2f65fc1f435a580 (patch)
treeb135a2f0a936e262c2650855ba444b57b4223f73 /dev-perl
parentmedia-video/streamdeck-ui: now it mostly works (diff)
downloadgentoo-19415adb30166c5821c2bb3ff2f65fc1f435a580.tar.gz
gentoo-19415adb30166c5821c2bb3ff2f65fc1f435a580.tar.bz2
gentoo-19415adb30166c5821c2bb3ff2f65fc1f435a580.zip
dev-perl/Chart-Math-Axis: -r bump for EAPI7
- EAPI7 - Rework dependencies to reflect current norms - Replace "sed" with an actual patch - Enable parallel testing Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/Chart-Math-Axis/Chart-Math-Axis-1.60.0-r3.ebuild30
-rw-r--r--dev-perl/Chart-Math-Axis/files/Chart-Math-Axis-1.06-no-dot-inc.patch21
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-perl/Chart-Math-Axis/Chart-Math-Axis-1.60.0-r3.ebuild b/dev-perl/Chart-Math-Axis/Chart-Math-Axis-1.60.0-r3.ebuild
new file mode 100644
index 000000000000..ddb74910ab11
--- /dev/null
+++ b/dev-perl/Chart-Math-Axis/Chart-Math-Axis-1.60.0-r3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=ADAMK
+DIST_VERSION=1.06
+inherit perl-module
+
+DESCRIPTION="Implements an algorithm to find good values for chart axis"
+
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=virtual/perl-Math-BigInt-1.700.0
+ >=dev-perl/Params-Util-0.150.0
+ >=virtual/perl-Storable-2.120.0
+"
+BDEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.420.0
+ test? (
+ >=virtual/perl-Test-Simple-0.420.0
+ )
+"
+PATCHES=(
+ "${FILESDIR}/${PN}-1.06-no-dot-inc.patch"
+)
diff --git a/dev-perl/Chart-Math-Axis/files/Chart-Math-Axis-1.06-no-dot-inc.patch b/dev-perl/Chart-Math-Axis/files/Chart-Math-Axis-1.06-no-dot-inc.patch
new file mode 100644
index 000000000000..2c52938ce7f5
--- /dev/null
+++ b/dev-perl/Chart-Math-Axis/files/Chart-Math-Axis-1.06-no-dot-inc.patch
@@ -0,0 +1,21 @@
+From 64874d89806ec13e6ae58a1b0720cf97dff92654 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Sat, 23 May 2020 07:48:07 +1200
+Subject: Include '.' in @INC on perl 5.26+
+
+---
+ Makefile.PL | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/Makefile.PL b/Makefile.PL
+index 54daf04..d6d71f3 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -1,3 +1,4 @@
++use lib '.';
+ use inc::Module::Install::DSL 1.00;
+
+ all_from lib/Chart/Math/Axis.pm
+--
+2.26.2
+