summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-12-17 22:00:03 +1300
committerKent Fredric <kentnl@gentoo.org>2017-12-17 22:03:26 +1300
commit2f4baf5e2131ea281340433e169fd9cb3ed0aa76 (patch)
tree9e8c4d706b86c56695df21035c8f0d2ec46ddb3c /dev-perl
parentdev-perl/Net-Z3950-ZOOM: EAPI6 + tests (diff)
downloadgentoo-2f4baf5e2131ea281340433e169fd9cb3ed0aa76.tar.gz
gentoo-2f4baf5e2131ea281340433e169fd9cb3ed0aa76.tar.bz2
gentoo-2f4baf5e2131ea281340433e169fd9cb3ed0aa76.zip
dev-perl/NetxAP: EAPI6 + tests
- EAPI6 - Enable tests - Fix tests failing due to Carp - Employ some patches from RT and Debian - Add USE=examples Package-Manager: Portage-2.3.18, Repoman-2.3.6
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/NetxAP/Manifest1
-rw-r--r--dev-perl/NetxAP/NetxAP-0.20.0-r2.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-perl/NetxAP/Manifest b/dev-perl/NetxAP/Manifest
index 49927b2d29ef..97efd7e906fe 100644
--- a/dev-perl/NetxAP/Manifest
+++ b/dev-perl/NetxAP/Manifest
@@ -1 +1,2 @@
+DIST NetxAP-0.02-patches-1.tar.xz 2912 BLAKE2B f07a22b792b6e876786fb54749d73e10ed9bce2c87c1f56395c53c0aeb0696d12e8ad6590bf33adbf922a57a2b21a9797907c2a205bc69ba0cdb8dfa5598d4ab SHA512 5b54ad9de0467cfdf2876c72552d9a5bd678dc717acd02187dce5d7f405c9a710e4ec65c5b9f44c1d7d0e111e04255e99d27a0fac7950c90df1713875605c28d
DIST NetxAP-0.02.tar.gz 33374 BLAKE2B 551dcdfe26836f7a3be4c92a5d1eb3e0ad9a14effd977e1d9263a55eff5d795a7e0899de75d1a3f1246b684b33726ec6aeaab763f4cdbe10dc2082f3b6528090 SHA512 72b2cb8e68f462f8dbbda6b1008344be5cd6b120ea7a7f14c3b83dc3f0b649171416cc1d86caefaf6732a9eea978a7fb502cd9315c9d4399d114f80caac8eccf
diff --git a/dev-perl/NetxAP/NetxAP-0.20.0-r2.ebuild b/dev-perl/NetxAP/NetxAP-0.20.0-r2.ebuild
new file mode 100644
index 000000000000..a4a234053305
--- /dev/null
+++ b/dev-perl/NetxAP/NetxAP-0.20.0-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=KJOHNSON
+DIST_VERSION=0.02
+DIST_EXAMPLES=("examples/*")
+
+inherit perl-module
+
+PATCH_BASE="${PN}-0.02-patches-1"
+
+DESCRIPTION="A base class for protocols such as IMAP, ACAP, IMSP, and ICAP"
+SRC_URI+=" mirror://gentoo/${PATCH_BASE}.tar.xz https://dev.gentoo.org/~kentnl/distfiles/${PATCH_BASE}.tar.xz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="virtual/perl-MIME-Base64
+ dev-perl/MD5
+ dev-perl/Digest-HMAC
+ virtual/perl-Digest-MD5
+"
+DEPEND="${RDEPEND}
+ test? (
+ net-mail/uw-imap
+ )
+"
+src_prepare() {
+ eapply "${WORKDIR}/patches"
+ perl-module_src_prepare
+}