summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-09-19 18:20:31 +1200
committerKent Fredric <kentnl@gentoo.org>2020-09-19 18:29:18 +1200
commit40272995d347d51cd494c0241679352348963d02 (patch)
tree94fd735d46b7dfc5b40a561c2122aefab93cc194 /dev-perl
parentprofiles/package.mask: mask rack:1.6 for removal (diff)
downloadgentoo-40272995d347d51cd494c0241679352348963d02.tar.gz
gentoo-40272995d347d51cd494c0241679352348963d02.tar.bz2
gentoo-40272995d347d51cd494c0241679352348963d02.zip
dev-perl/forks: -r bump for EAPI7 + CFLAGS love
- EAPI7 - Ensure CFLAGS passed to make/compiler - Strip bad tests - Expand deps slightly - Addd missing remote-id's Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/forks/forks-0.360.0-r2.ebuild42
-rw-r--r--dev-perl/forks/metadata.xml4
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-perl/forks/forks-0.360.0-r2.ebuild b/dev-perl/forks/forks-0.360.0-r2.ebuild
new file mode 100644
index 000000000000..be6e9c05d072
--- /dev/null
+++ b/dev-perl/forks/forks-0.360.0-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=RYBSKEJ
+DIST_VERSION=0.36
+inherit perl-module
+
+DESCRIPTION="Emulate threads with fork"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-perl/Acme-Damn
+ virtual/perl-Attribute-Handlers
+ dev-perl/Devel-Symdump
+ virtual/perl-File-Spec
+ >=virtual/perl-IO-1.180.0
+ >=dev-perl/List-MoreUtils-0.150.0
+ >=virtual/perl-Scalar-List-Utils-1.110.0
+ virtual/perl-Storable
+ >=dev-perl/Sys-SigAction-0.110.0
+ virtual/perl-Time-HiRes
+ virtual/perl-if
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( virtual/perl-Test-Simple )
+"
+PERL_RM_FILES=(
+ t/forks99.t
+)
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}
diff --git a/dev-perl/forks/metadata.xml b/dev-perl/forks/metadata.xml
index 647612455f5f..3bb1dbb04d5c 100644
--- a/dev-perl/forks/metadata.xml
+++ b/dev-perl/forks/metadata.xml
@@ -9,5 +9,9 @@
<remote-id type="cpan">forks</remote-id>
<remote-id type="cpan-module">forks</remote-id>
<remote-id type="cpan-module">forks::shared</remote-id>
+ <remote-id type="cpan-module">threads::shared::array</remote-id>
+ <remote-id type="cpan-module">threads::shared::handle</remote-id>
+ <remote-id type="cpan-module">threads::shared::hash</remote-id>
+ <remote-id type="cpan-module">threads::shared::scalar</remote-id>
</upstream>
</pkgmetadata>