summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-06-01 03:00:23 +0100
committerSam James <sam@gentoo.org>2022-06-01 03:00:23 +0100
commit427867cd760a81605b7138bf2e2595a0b98e1939 (patch)
treec792159961a852bb8921accb3dd9b1df9f4c3010 /dev-perl
parentapp-editors/qhexedit2: Stabilize 0.8.9_p20210525-r2 amd64, #825670 (diff)
downloadgentoo-427867cd760a81605b7138bf2e2595a0b98e1939.tar.gz
gentoo-427867cd760a81605b7138bf2e2595a0b98e1939.tar.bz2
gentoo-427867cd760a81605b7138bf2e2595a0b98e1939.zip
dev-perl/Net-DNS: add 1.340.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/Net-DNS/Manifest1
-rw-r--r--dev-perl/Net-DNS/Net-DNS-1.340.0.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-perl/Net-DNS/Manifest b/dev-perl/Net-DNS/Manifest
index b54aae389812..a2d5e92895f8 100644
--- a/dev-perl/Net-DNS/Manifest
+++ b/dev-perl/Net-DNS/Manifest
@@ -1,2 +1,3 @@
DIST Net-DNS-1.31.tar.gz 249299 BLAKE2B d8456453240e388476ef918cc7731b9d790b8163885e18658182d927c2a594cb74a7983d33607d495c75b7638efd7bd2bb6368e1b5ec80e4eca9e809ba6bc97c SHA512 f406bc192f18b0a07171f3e81209ca705b9fa5fa8104533cbece1678bb08220636b438aa3a4a6a5f2d03a3a3166503a9fa8c5c16f92b1b3e8f8e2e2fdf0f8ddb
DIST Net-DNS-1.32.tar.gz 259004 BLAKE2B 55142e3c345ba702d66fa5f3c765ce4b2e2049f0586a839cc1415b65c04dde043b134f156cea2718517c739b7679757bbafcd7e8206d95da537327e9e93fd955 SHA512 1bf164b1e80478eecd5b3a5cdb1362fc89d320505e9e74c47d877a9737882fff8b78580134d921e19d3ecb149b4815e9868cdd5b6ecea2549e1bc61a32331a3d
+DIST Net-DNS-1.34.tar.gz 260260 BLAKE2B 1a2d9aa15757efb25e0b70ceb7e07f446be33c1e4e30ebc343cbc44489ead69c3e7e958a68fb52963f409579bbc50f2c198b38d92c6624edbcab05aac2d1e60b SHA512 890b5e7b574a546337571a8c7f5836650a7de41301ce2386d973041f0f1da0bd40c69cfc3625fccd01685502017b42d23cd75e95f40a1ffd7bcc796385899032
diff --git a/dev-perl/Net-DNS/Net-DNS-1.340.0.ebuild b/dev-perl/Net-DNS/Net-DNS-1.340.0.ebuild
new file mode 100644
index 000000000000..59944ff5e795
--- /dev/null
+++ b/dev-perl/Net-DNS/Net-DNS-1.340.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=NLNETLABS
+DIST_VERSION=1.34
+DIST_EXAMPLES=( "contrib" "demo" )
+inherit toolchain-funcs perl-module
+
+DESCRIPTION="Perl Interface to the Domain Name System"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="minimal"
+
+PDEPEND="
+ !minimal? ( >=dev-perl/Net-DNS-SEC-1.30.0 )
+"
+RDEPEND="
+ >=virtual/perl-Carp-1.100.0
+ >=dev-perl/Digest-HMAC-1.30.0
+ >=virtual/perl-Digest-MD5-2.130.0
+ >=virtual/perl-Digest-SHA-5.230.0
+ >=virtual/perl-Encode-2.260.0
+ >=virtual/perl-Exporter-5.560.0
+ >=virtual/perl-File-Spec-0.860.0
+ >=virtual/perl-MIME-Base64-2.130.0
+ >=virtual/perl-Scalar-List-Utils-1.250.0
+ >=virtual/perl-Time-Local-1.190.0
+ >=virtual/perl-IO-Socket-IP-0.380.0
+ >=virtual/perl-IO-1.80.0
+ !minimal? (
+ >=dev-perl/Digest-BubbleBabble-0.10.0
+ >=dev-perl/Net-LibIDN2-1.0.0
+ )
+"
+BDEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.660.0
+ >=virtual/perl-Getopt-Long-2.430.0
+ test? (
+ >=virtual/perl-Test-Simple-0.520.0
+ )
+"
+
+src_prepare() {
+ perl-module_src_prepare
+ mydoc="TODO"
+ # --IPv6-tests requires that you have external IPv6 connectivity
+ # as it connects to 2001:7b8:206:1:0:1234:be21:e31e
+ if ! use test || ! has network ${DIST_TEST_OVERRIDE:-${DIST_TEST:-do parallel}}; then
+ myconf="${myconf} --no-online-tests --no-IPv6-tests"
+ fi
+}
+
+src_compile() {
+ emake FULL_AR="$(tc-getAR)" OTHERLDFLAGS="${LDFLAGS}"
+}
+
+src_test() {
+ perl_rm_files t/00-pod.t
+ if ! has network ${DIST_TEST_OVERRIDE:-${DIST_TEST:-do parallel}}; then
+ elog "Network tests disabled without to DIST_TEST_OVERIDE=~network"
+ fi
+ perl-module_src_test
+}