summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-10-07 21:31:07 +1300
committerKent Fredric <kentnl@gentoo.org>2020-10-07 21:31:41 +1300
commit4da1128ee63cefb76389ee2bf154df5f784dbf82 (patch)
tree44b3fbc5805dd9211b5855c0ae4c03f239d0a8b6 /dev-perl
parentvirtual/rust: 1.46.0 arm64 stable, bug #746971 (diff)
downloadgentoo-4da1128ee63cefb76389ee2bf154df5f784dbf82.tar.gz
gentoo-4da1128ee63cefb76389ee2bf154df5f784dbf82.tar.bz2
gentoo-4da1128ee63cefb76389ee2bf154df5f784dbf82.zip
dev-perl/Carp-Assert-More: Bump to version 1.240.0
- Fix LICENSE Upstream: - Add assert_keys_are(\%hash, \@exact_keylist [, $test_name ] ) - assert_datetime() now has a prototype - Minimum Perl reduced to perl 5.6.1 by removing use of defined-or Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/Carp-Assert-More/Carp-Assert-More-1.240.0.ebuild41
-rw-r--r--dev-perl/Carp-Assert-More/Manifest1
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-perl/Carp-Assert-More/Carp-Assert-More-1.240.0.ebuild b/dev-perl/Carp-Assert-More/Carp-Assert-More-1.240.0.ebuild
new file mode 100644
index 000000000000..be2c307e5001
--- /dev/null
+++ b/dev-perl/Carp-Assert-More/Carp-Assert-More-1.240.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=PETDANCE
+DIST_VERSION=1.24
+inherit perl-module
+
+DESCRIPTION="convenience wrappers around Carp::Assert"
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ virtual/perl-Carp
+ dev-perl/Carp-Assert
+ virtual/perl-Scalar-List-Utils
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ dev-perl/Test-Exception
+ )
+"
+PERL_RM_FILES=(
+ "t/pod-coverage.t"
+ "t/pod.t"
+)
+src_test() {
+ perl-module_src_test
+ local MODULES=(
+ "Carp::Assert::More ${DIST_VERSION}"
+ )
+ for dep in "${MODULES[@]}"; do
+ perl -Mblib="${S}" -M"${dep} ()" -e1 ||
+ die "Could not load ${dep}"
+ done
+}
diff --git a/dev-perl/Carp-Assert-More/Manifest b/dev-perl/Carp-Assert-More/Manifest
index 6f71e4165f95..81c540fb84b1 100644
--- a/dev-perl/Carp-Assert-More/Manifest
+++ b/dev-perl/Carp-Assert-More/Manifest
@@ -1 +1,2 @@
DIST Carp-Assert-More-1.20.tar.gz 13282 BLAKE2B aa85111f076f78d0de2e4568b2ddb3c1318c5dae76da3b29f442e07e7b4f729c62abf94bc320477f1c572c6ff64d87c30793fb64e88f0774cba873c7f5aa8ffd SHA512 9caacf2cc4acb190b071a7312e5e1cdee5a0b7a0e9db0efc6dca0fa19167524a3bd6beecc4bb8e68eace719fc1d918063e9d259a24cb28e81dd628ea75ba541b
+DIST Carp-Assert-More-1.24.tar.gz 14414 BLAKE2B 0a0a710a9248956cd6a6cf72c200348d8ed9183d54c1b2754ed8a1c2af542f87c425d8808cb7b4c930d547ee6282ed577c43f12141898c2b9cdad82ace71cc0d SHA512 60b4d21ea90822f182a9b166489146c73d7c5230de1910b4f23bab9cdf85b93d4b8e1e9792f57808a984dcd63179197d0229fa4b812693808cfa89bb6685bf00