summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-06-11 15:39:29 +1200
committerKent Fredric <kentnl@gentoo.org>2017-06-11 15:39:29 +1200
commit798cf050aa98601af4a471c55a52f06b3b2996b4 (patch)
tree590b91f9d35486b9d87a4acc66efcb2b2880d045 /dev-perl
parentdev-perl/Class-Accessor-Lite: Fix for '.' in @INC re bug #613708 (diff)
downloadgentoo-798cf050aa98601af4a471c55a52f06b3b2996b4.tar.gz
gentoo-798cf050aa98601af4a471c55a52f06b3b2996b4.tar.bz2
gentoo-798cf050aa98601af4a471c55a52f06b3b2996b4.zip
dev-perl/Crypt-Twofish: Fix for '.' in @INC re bug #615018
This simply adjusts a legacy case where there was an explicit: require "some/path" Where it was assumed "some/path" would be relative to cwd, which is no longer the case sinc '.' was removed from @INC Bug: https://bugs.gentoo.org/615018 Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/Crypt-Twofish/Crypt-Twofish-2.170.0-r1.ebuild4
-rw-r--r--dev-perl/Crypt-Twofish/files/no-dot-inc.patch32
2 files changed, 34 insertions, 2 deletions
diff --git a/dev-perl/Crypt-Twofish/Crypt-Twofish-2.170.0-r1.ebuild b/dev-perl/Crypt-Twofish/Crypt-Twofish-2.170.0-r1.ebuild
index 27f16da7a064..39165dbb2c93 100644
--- a/dev-perl/Crypt-Twofish/Crypt-Twofish-2.170.0-r1.ebuild
+++ b/dev-perl/Crypt-Twofish/Crypt-Twofish-2.170.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -12,5 +12,5 @@ DESCRIPTION="The Twofish Encryption Algorithm"
SLOT="0"
KEYWORDS="amd64 ia64 ~ppc ~sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
IUSE=""
-
+PATCHES=("${FILESDIR}/no-dot-inc.patch")
SRC_TEST="do"
diff --git a/dev-perl/Crypt-Twofish/files/no-dot-inc.patch b/dev-perl/Crypt-Twofish/files/no-dot-inc.patch
new file mode 100644
index 000000000000..a3b26afe821c
--- /dev/null
+++ b/dev-perl/Crypt-Twofish/files/no-dot-inc.patch
@@ -0,0 +1,32 @@
+From 0906d6c153b3bedad2a91a19e8441b9633070e10 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentfredric@gmail.com>
+Date: Sun, 11 Jun 2017 15:29:53 +1200
+Subject: [PATCH] Fix tab/tables.pl for Perl 5.26
+
+Removal of "." from @INC means require $PATH no longer ever assumes
+a path relative to ".", and instead must be explicitly stated with a
+leading "./"
+
+Fixes RT#120087
+
+Bug: https://rt.cpan.org/Ticket/Display.html?id=120087
+---
+ tab/tables.pl | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tab/tables.pl b/tab/tables.pl
+index 2aa0c66..7bed411 100644
+--- a/tab/tables.pl
++++ b/tab/tables.pl
+@@ -3,7 +3,7 @@
+ # Copyright 2001 Abhijit Menon-Sen <ams@wiw.org>
+
+ use strict;
+-require 'tab/misc.pl';
++require './tab/misc.pl';
+
+ my ($qtab, $mtab) = ([], []);
+
+--
+2.13.1
+