summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2019-07-11 02:07:49 +1200
committerKent Fredric <kentnl@gentoo.org>2019-07-11 02:07:49 +1200
commit990320f0a0a778e3b5daf82f77b6eafff7c79069 (patch)
treef7b56ace908a926c13918ca1352b777751474415 /dev-perl
parentdev-perl/DBD-MariaDB: Add w/ version 1.210.0 re bug #669624 (diff)
downloadgentoo-990320f0a0a778e3b5daf82f77b6eafff7c79069.tar.gz
gentoo-990320f0a0a778e3b5daf82f77b6eafff7c79069.tar.bz2
gentoo-990320f0a0a778e3b5daf82f77b6eafff7c79069.zip
dev-perl/DBD-MariaDB: Minor improvements in configure
- Simplify handling provider for backend - Auto-chomp EROOT for future compat with EAPI7 Package-Manager: Portage-2.3.66, Repoman-2.3.16 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/DBD-MariaDB/DBD-MariaDB-1.210.0.ebuild10
1 files changed, 3 insertions, 7 deletions
diff --git a/dev-perl/DBD-MariaDB/DBD-MariaDB-1.210.0.ebuild b/dev-perl/DBD-MariaDB/DBD-MariaDB-1.210.0.ebuild
index f87dcb390c34..c9433204e7dc 100644
--- a/dev-perl/DBD-MariaDB/DBD-MariaDB-1.210.0.ebuild
+++ b/dev-perl/DBD-MariaDB/DBD-MariaDB-1.210.0.ebuild
@@ -47,19 +47,15 @@ PERL_RM_FILES=(
)
src_configure() {
-
+ local impl
+ impl=$(usex mariadb mariadb mysql)
if use test; then
myconf="${myconf} --testdb=test \
--testhost=localhost \
--testuser=test \
--testpassword=test"
fi
- if use mysql; then
- myconf+=" --mysql_config=${EROOT}usr/bin/mysql_config"
- fi
- if use mariadb; then
- myconf+=" --mariadb_config=${EROOT}usr/bin/mariadb_config"
- fi
+ myconf+=" --${impl}_config=${EROOT%/}/usr/bin/${impl}_config"
perl-module_src_configure
}