summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-10-24 11:57:42 +0200
committerPacho Ramos <pacho@gentoo.org>2015-10-24 11:57:52 +0200
commit9c0ef2be161719a22579fbc0a24963ad05b3c73b (patch)
tree26ea949a68012a362d02df45520ea7ca0294f628 /dev-perl
parentmedia-video/mkvtoolnix: Bump to 8.5.1 (diff)
downloadgentoo-9c0ef2be161719a22579fbc0a24963ad05b3c73b.tar.gz
gentoo-9c0ef2be161719a22579fbc0a24963ad05b3c73b.tar.bz2
gentoo-9c0ef2be161719a22579fbc0a24963ad05b3c73b.zip
dev-perl/Wx-Scintilla: Support wxGTK:3.0
Package-Manager: portage-2.2.23
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/Wx-Scintilla/Wx-Scintilla-0.390.0-r2.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-perl/Wx-Scintilla/Wx-Scintilla-0.390.0-r2.ebuild b/dev-perl/Wx-Scintilla/Wx-Scintilla-0.390.0-r2.ebuild
new file mode 100644
index 000000000000..85360c651e12
--- /dev/null
+++ b/dev-perl/Wx-Scintilla/Wx-Scintilla-0.390.0-r2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+WX_GTK_VER="3.0"
+#VIRTUALX_REQUIRED=test
+#inherit virtualx
+MODULE_AUTHOR=AZAWAWI
+MODULE_VERSION=0.39
+inherit wxwidgets perl-module
+
+DESCRIPTION="Scintilla source code editing component for wxWidgets"
+SRC_URI+=" https://dev.gentoo.org/~tove/distfiles/dev-perl/${PN}-0.34-patches.tar.gz"
+
+LICENSE+=" HPND"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-perl/Alien-wxWidgets
+ dev-perl/wxperl
+ x11-libs/wxGTK:${WX_GTK_VER}
+"
+DEPEND="${RDEPEND}
+ >=dev-perl/ExtUtils-XSpp-0.160.200
+ >=dev-perl/Module-Build-0.360.0
+"
+
+PATCHES=(
+ "${WORKDIR}"/${PN}-patches/0.34-flags.patch
+)
+
+src_configure() {
+ need-wxwidgets base-unicode
+ myconf=( --verbose )
+ perl-module_src_configure
+}
+
+#SRC_TEST=do
+#src_test() {
+# VIRTUALX_COMMAND="./Build" virtualmake test || die
+#}