summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2019-04-24 15:44:56 -0400
committerBrian Evans <grknight@gentoo.org>2019-04-24 15:45:45 -0400
commit246fc7dcc4d45f900306cd78a7abf11f473dedb8 (patch)
tree240013b72c654d81cde7d3890fc1058a2e1a06eb /dev-php/PEAR-Archive_Tar
parentdev-php/PEAR-HTML_QuickForm2: Version bump for 2.1.0 (diff)
downloadgentoo-246fc7dcc4d45f900306cd78a7abf11f473dedb8.tar.gz
gentoo-246fc7dcc4d45f900306cd78a7abf11f473dedb8.tar.bz2
gentoo-246fc7dcc4d45f900306cd78a7abf11f473dedb8.zip
dev-php/PEAR-Archive_Tar: Version bump for 1.4.7
Package-Manager: Portage-2.3.64, Repoman-2.3.12 Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'dev-php/PEAR-Archive_Tar')
-rw-r--r--dev-php/PEAR-Archive_Tar/Manifest1
-rw-r--r--dev-php/PEAR-Archive_Tar/PEAR-Archive_Tar-1.4.7.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-php/PEAR-Archive_Tar/Manifest b/dev-php/PEAR-Archive_Tar/Manifest
index b3720b5601ca..067ea39c0b89 100644
--- a/dev-php/PEAR-Archive_Tar/Manifest
+++ b/dev-php/PEAR-Archive_Tar/Manifest
@@ -1 +1,2 @@
DIST Archive_Tar-1.4.5.tgz 20919 BLAKE2B 506b2fae8f99634cf40ecff9c5ec695c101f4e14ae867795851a7e238a62c2611581aaab1cc0e9a9354184b20ba141f29ae3998881e7ebf777c596e5dc251577 SHA512 7a7e16e37b0c7112a77333ed2c4d0a0ae57cc1e971191c79b1858227b46f967aee915757a81bdfef3a9487a53b81a99bfbe84f78a346671fe44ac9f1f203a358
+DIST Archive_Tar-1.4.7.tgz 21134 BLAKE2B 15bc4e7f74a61062d10fa69bb826bbf92dbee6fc3f45da32a2b25964f3e042c0559e0614be13592b68cdea0a819315f43c4331d9dc90e94dd3c773f38c379e99 SHA512 e496fdcb1e7a2bbbc4aae88bae5793b0da6e7e7ee0ebbab78de14279cc3a5b7a2ec30d1424c3977ba6e4edd4780c0cb8dcf4288a7495252e28c560b8781d5b75
diff --git a/dev-php/PEAR-Archive_Tar/PEAR-Archive_Tar-1.4.7.ebuild b/dev-php/PEAR-Archive_Tar/PEAR-Archive_Tar-1.4.7.ebuild
new file mode 100644
index 000000000000..025fa048e203
--- /dev/null
+++ b/dev-php/PEAR-Archive_Tar/PEAR-Archive_Tar-1.4.7.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="${PN/PEAR-/}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Tar file management class"
+HOMEPAGE="https://pear.php.net/package/${MY_PN}"
+SRC_URI="https://pear.php.net/get/${MY_P}.tgz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+# bzip2 and zlib are needed for compressed tarballs, and there's one
+# call to preg_match to test paths against a pattern of files and
+# directories that will be ignored.
+RDEPEND="dev-lang/php:*[bzip2,pcre(+),zlib]"
+PDEPEND="dev-php/PEAR-PEAR"
+DEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ insinto /usr/share/php
+ doins -r Archive
+
+ dodoc docs/*
+}