summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2017-03-20 23:37:15 -0400
committerMichael Orlitzky <mjo@gentoo.org>2017-03-20 23:39:23 -0400
commit1c6d9aeb1b7022cfafd0600dec52909ef0e31f73 (patch)
tree4ef8e0068e226ba1cc77e1d6f21890f2ddb54efa /dev-php/PEAR-Exception/PEAR-Exception-1.0.0.ebuild
parentdev-perl/Capture-Tiny: Bump to version 0.460.0 (diff)
downloadgentoo-1c6d9aeb1b7022cfafd0600dec52909ef0e31f73.tar.gz
gentoo-1c6d9aeb1b7022cfafd0600dec52909ef0e31f73.tar.bz2
gentoo-1c6d9aeb1b7022cfafd0600dec52909ef0e31f73.zip
dev-php/PEAR-Exception: new package supplying the PEAR/Exception class.
Right now, most of the dev-php/PEAR-* packages in the tree depend on dev-php/PEAR-PEAR. However, most of them only need to do so for one class, PEAR/Exception. This new package (a legit, separate upstream package) provides that class and nothing else. Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-php/PEAR-Exception/PEAR-Exception-1.0.0.ebuild')
-rw-r--r--dev-php/PEAR-Exception/PEAR-Exception-1.0.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-php/PEAR-Exception/PEAR-Exception-1.0.0.ebuild b/dev-php/PEAR-Exception/PEAR-Exception-1.0.0.ebuild
new file mode 100644
index 000000000000..7795167c287c
--- /dev/null
+++ b/dev-php/PEAR-Exception/PEAR-Exception-1.0.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="${PN/-/_}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="The PEAR Exception base class"
+HOMEPAGE="http://pear.php.net/package/${MY_PN}"
+SRC_URI="http://download.pear.php.net/package/${MY_P}.tgz"
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RDEPEND="dev-lang/php:*
+ !<=dev-php/PEAR-PEAR-1.10.3-r1"
+DEPEND="test? ( ${RDEPEND} dev-php/phpunit )"
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ insinto /usr/share/php
+ doins -r PEAR
+}
+
+src_test() {
+ phpunit tests || die "test suite failed"
+}