summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2017-07-06 09:22:17 -0400
committerBrian Evans <grknight@gentoo.org>2017-07-06 10:36:22 -0400
commitb7245c2eec0059fc65676625c69516bd716915b7 (patch)
tree5a61ce5235efc4488087c6432f0bd182997d4156 /dev-php/PEAR-HTML_QuickForm_advmultiselect/PEAR-HTML_QuickForm_advmultiselect-1.5.1-r1.ebuild
parentdev-ros/urdf_tutorial: update live ebiuld to match upstream (diff)
downloadgentoo-b7245c2eec0059fc65676625c69516bd716915b7.tar.gz
gentoo-b7245c2eec0059fc65676625c69516bd716915b7.tar.bz2
gentoo-b7245c2eec0059fc65676625c69516bd716915b7.zip
dev-php/PEAR-HTML_QuickForm_advmultiselect: Revbump for EAPI and eclass changes
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-php/PEAR-HTML_QuickForm_advmultiselect/PEAR-HTML_QuickForm_advmultiselect-1.5.1-r1.ebuild')
-rw-r--r--dev-php/PEAR-HTML_QuickForm_advmultiselect/PEAR-HTML_QuickForm_advmultiselect-1.5.1-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-php/PEAR-HTML_QuickForm_advmultiselect/PEAR-HTML_QuickForm_advmultiselect-1.5.1-r1.ebuild b/dev-php/PEAR-HTML_QuickForm_advmultiselect/PEAR-HTML_QuickForm_advmultiselect-1.5.1-r1.ebuild
new file mode 100644
index 000000000000..2fecac65621a
--- /dev/null
+++ b/dev-php/PEAR-HTML_QuickForm_advmultiselect/PEAR-HTML_QuickForm_advmultiselect-1.5.1-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit php-pear-r2
+
+DESCRIPTION="Element for HTML_QuickForm that emulate a multi-select"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+RDEPEND=">=dev-php/PEAR-HTML_QuickForm-3.2.10
+ >=dev-php/PEAR-HTML_Common-1.2.5"
+
+src_install() {
+ local HTML_DOCS=( qfamsHandler.js qfamsHandler-min.js )
+ use examples && HTML_DOCS+=( examples )
+ insinto /usr/share/php/HTML/QuickForm
+ doins advmultiselect.php
+ php-pear-r2_install_packagexml
+ einstalldocs
+}