summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2021-07-24 15:45:09 +0200
committerThomas Deutschmann <whissi@gentoo.org>2021-07-24 18:15:28 +0200
commit32a49b3254b2d5d202fc546f0a12a18860b7e445 (patch)
tree739cc6deeb1e5198b9994fddbafc9f2ef6f03456 /dev-php/PEAR-HTTP_Request2/PEAR-HTTP_Request2-2.5.0.ebuild
parentdev-php/pecl-imagick: bump to v3.5.1 (diff)
downloadgentoo-32a49b3254b2d5d202fc546f0a12a18860b7e445.tar.gz
gentoo-32a49b3254b2d5d202fc546f0a12a18860b7e445.tar.bz2
gentoo-32a49b3254b2d5d202fc546f0a12a18860b7e445.zip
dev-php/PEAR-HTTP_Request2: bump to v2.5.0
Package-Manager: Portage-3.0.21, Repoman-3.0.3 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php/PEAR-HTTP_Request2/PEAR-HTTP_Request2-2.5.0.ebuild')
-rw-r--r--dev-php/PEAR-HTTP_Request2/PEAR-HTTP_Request2-2.5.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-php/PEAR-HTTP_Request2/PEAR-HTTP_Request2-2.5.0.ebuild b/dev-php/PEAR-HTTP_Request2/PEAR-HTTP_Request2-2.5.0.ebuild
new file mode 100644
index 000000000000..890fa326e01c
--- /dev/null
+++ b/dev-php/PEAR-HTTP_Request2/PEAR-HTTP_Request2-2.5.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit php-pear-r2
+
+DESCRIPTION="Provides an easy way to perform HTTP requests"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="+curl +fileinfo +ssl test +zlib"
+
+# We don't have Yoast\PHPUnitPolyfills in Gentoo
+# and we would need to patch sources to find it
+RESTRICT="test"
+
+RDEPEND="dev-lang/php:*[curl?,fileinfo?,ssl?,zlib?]
+>=dev-php/PEAR-Net_URL2-2.2.0"
+DEPEND="test? ( ${RDEPEND} dev-php/phpunit )"
+
+src_prepare() {
+ sed -i "s~@data_dir@~${EPREFIX}/usr/share/php/data~" HTTP/Request2/CookieJar.php || die
+ default
+}
+
+src_test() {
+ phpunit tests || die
+}
+
+src_install() {
+ php-pear-r2_src_install
+ insinto "/usr/share/php/data/${PHP_PEAR_PKG_NAME}"
+ doins data/*
+}