summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2016-07-27 15:01:11 -0400
committerMichael Orlitzky <mjo@gentoo.org>2016-07-27 15:19:39 -0400
commitb2c8e7c84bda674d5a55ed253d2e4b429c295b16 (patch)
treea417ee74816080b72f0ca93c5fce75232d837c20 /dev-php/PEAR-Net_LDAP2/PEAR-Net_LDAP2-2.2.0-r1.ebuild
parentdev-php/PEAR-Net_Sieve: new revision adding missing RDEPEND dev-php/PEAR-PEAR. (diff)
downloadgentoo-b2c8e7c84bda674d5a55ed253d2e4b429c295b16.tar.gz
gentoo-b2c8e7c84bda674d5a55ed253d2e4b429c295b16.tar.bz2
gentoo-b2c8e7c84bda674d5a55ed253d2e4b429c295b16.zip
dev-php/PEAR-Net_LDAP2: new revision to add missing RDEPEND dev-php/PEAR-PEAR.
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-php/PEAR-Net_LDAP2/PEAR-Net_LDAP2-2.2.0-r1.ebuild')
-rw-r--r--dev-php/PEAR-Net_LDAP2/PEAR-Net_LDAP2-2.2.0-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-php/PEAR-Net_LDAP2/PEAR-Net_LDAP2-2.2.0-r1.ebuild b/dev-php/PEAR-Net_LDAP2/PEAR-Net_LDAP2-2.2.0-r1.ebuild
new file mode 100644
index 000000000000..ac08f357d602
--- /dev/null
+++ b/dev-php/PEAR-Net_LDAP2/PEAR-Net_LDAP2-2.2.0-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+MY_PN="${PN/PEAR-/}"
+KEYWORDS="~amd64 ~hppa ~x86"
+DESCRIPTION="OO interface for searching and manipulating LDAP-entries"
+HOMEPAGE="https://pear.php.net/package/${MY_PN}"
+SRC_URI="http://download.pear.php.net/package/${MY_PN}-${PV}.tgz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="examples test"
+
+RDEPEND="dev-lang/php:*[ldap]
+ dev-php/PEAR-PEAR"
+DEPEND="test? ( ${RDEPEND} dev-php/phpunit )"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_install() {
+ use examples && dodoc -r doc/examples
+ dodoc doc/*.*
+ insinto /usr/share/php
+ doins -r Net
+}
+
+src_test() {
+ phpunit tests/ || die "test suite failed"
+}