summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2017-02-28 09:02:07 -0500
committerBrian Evans <grknight@gentoo.org>2017-02-28 09:02:07 -0500
commit20b1281c200a0c385f59c5cff8ab2020e299e2d8 (patch)
tree61c4aed770da59df3a8ebffd530ea83acb1e551d /dev-php/PEAR-OLE/PEAR-OLE-1.0.0_rc2-r2.ebuild
parentdev-python/bpython: python3_6 added (diff)
downloadgentoo-20b1281c200a0c385f59c5cff8ab2020e299e2d8.tar.gz
gentoo-20b1281c200a0c385f59c5cff8ab2020e299e2d8.tar.bz2
gentoo-20b1281c200a0c385f59c5cff8ab2020e299e2d8.zip
dev-php/PEAR-OLE: Revision bump to include patches from upstream wrt bug 611162
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-php/PEAR-OLE/PEAR-OLE-1.0.0_rc2-r2.ebuild')
-rw-r--r--dev-php/PEAR-OLE/PEAR-OLE-1.0.0_rc2-r2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-php/PEAR-OLE/PEAR-OLE-1.0.0_rc2-r2.ebuild b/dev-php/PEAR-OLE/PEAR-OLE-1.0.0_rc2-r2.ebuild
new file mode 100644
index 000000000000..65a1974193cd
--- /dev/null
+++ b/dev-php/PEAR-OLE/PEAR-OLE-1.0.0_rc2-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+MY_PN="${PN/PEAR-/}"
+MY_PV="${PV/_/}"
+MY_PV="${MY_PV^^}"
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="Package for reading and writing OLE containers"
+HOMEPAGE="http://pear.php.net/package/${MY_PN}"
+SRC_URI="http://download.pear.php.net/package/${MY_P}.tgz"
+LICENSE="PHP-3.01"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/php:*
+ dev-php/PEAR-PEAR"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ eapply "${FILESDIR}/pear-bug-19284.patch" \
+ "${FILESDIR}/${PV}-fix-static-calls.patch"
+ eapply_user
+}
+
+src_install() {
+ insinto /usr/share/php
+ doins "${MY_PN}.php"
+ doins -r "${MY_PN}"
+}