summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2018-02-15 12:40:15 -0500
committerBrian Evans <grknight@gentoo.org>2018-02-15 12:40:15 -0500
commitfd1b21ca74ca7aa419199d6b1c293105aede7517 (patch)
tree35ebf272398e0fba22a83ff25b728fb4da48eddc /dev-php/PEAR-Services_JSON
parentapp-shells/ksh: bump to 93.20180215 (diff)
downloadgentoo-fd1b21ca74ca7aa419199d6b1c293105aede7517.tar.gz
gentoo-fd1b21ca74ca7aa419199d6b1c293105aede7517.tar.bz2
gentoo-fd1b21ca74ca7aa419199d6b1c293105aede7517.zip
dev-php/PEAR-Services_JSON: Add an additional upstream patch
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-php/PEAR-Services_JSON')
-rw-r--r--dev-php/PEAR-Services_JSON/PEAR-Services_JSON-1.0.3-r1.ebuild2
-rw-r--r--dev-php/PEAR-Services_JSON/files/JSON-1.0.3-constructor.patch2
-rw-r--r--dev-php/PEAR-Services_JSON/files/JSON-1.0.3-upstream-typo.patch20
3 files changed, 22 insertions, 2 deletions
diff --git a/dev-php/PEAR-Services_JSON/PEAR-Services_JSON-1.0.3-r1.ebuild b/dev-php/PEAR-Services_JSON/PEAR-Services_JSON-1.0.3-r1.ebuild
index 7203bc34815a..9e52d443b4b0 100644
--- a/dev-php/PEAR-Services_JSON/PEAR-Services_JSON-1.0.3-r1.ebuild
+++ b/dev-php/PEAR-Services_JSON/PEAR-Services_JSON-1.0.3-r1.ebuild
@@ -10,7 +10,7 @@ DESCRIPTION="PHP implementaion of json_encode/decode"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-PATCHES=( "${FILESDIR}/JSON-1.0.3-constructor.patch" )
+PATCHES=( "${FILESDIR}/JSON-1.0.3-upstream-typo.patch" "${FILESDIR}/JSON-1.0.3-constructor.patch" )
src_install() {
php-pear-r2_src_install
diff --git a/dev-php/PEAR-Services_JSON/files/JSON-1.0.3-constructor.patch b/dev-php/PEAR-Services_JSON/files/JSON-1.0.3-constructor.patch
index d9d63fc28fcd..d7348f0f858e 100644
--- a/dev-php/PEAR-Services_JSON/files/JSON-1.0.3-constructor.patch
+++ b/dev-php/PEAR-Services_JSON/files/JSON-1.0.3-constructor.patch
@@ -35,7 +35,7 @@ diff -aurN a/JSON.php b/JSON.php
+ function __construct($message = 'unknown error', $code = null,
+ $mode = null, $options = null, $userinfo = null)
+ {
-+
++ return;
+ }
function Services_JSON_Error($message = 'unknown error', $code = null,
$mode = null, $options = null, $userinfo = null)
diff --git a/dev-php/PEAR-Services_JSON/files/JSON-1.0.3-upstream-typo.patch b/dev-php/PEAR-Services_JSON/files/JSON-1.0.3-upstream-typo.patch
new file mode 100644
index 000000000000..c7d8be3aa910
--- /dev/null
+++ b/dev-php/PEAR-Services_JSON/files/JSON-1.0.3-upstream-typo.patch
@@ -0,0 +1,20 @@
+--- a/JSON.php 2011/01/28 00:16:42 307804
++++ b/JSON.php 2013/04/30 02:37:26 330165
+@@ -554,7 +544,7 @@
+
+ return ($this->use & SERVICES_JSON_SUPPRESS_ERRORS)
+ ? 'null'
+- : new Services_JSON_Error(class_name($var).
++ : new Services_JSON_Error(get_class($var).
+ " toJSON returned an object with a toJSON method.");
+
+ }
+@@ -995,7 +985,7 @@
+ function Services_JSON_Error($message = 'unknown error', $code = null,
+ $mode = null, $options = null, $userinfo = null)
+ {
+-
++ return;
+ }
+ }
+