summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2017-01-09 14:15:53 -0500
committerMichael Orlitzky <mjo@gentoo.org>2017-01-09 14:46:01 -0500
commit96a7850b106fa760fc07f99a5227c7c6e6272ebe (patch)
tree18f5dd48d807abd5d4f795dc236f839dc08fce53 /dev-php/PEAR-Services_W3C_CSSValidator/PEAR-Services_W3C_CSSValidator-0.2.3.ebuild
parentdev-util/meson: add live ebuild (diff)
downloadgentoo-96a7850b106fa760fc07f99a5227c7c6e6272ebe.tar.gz
gentoo-96a7850b106fa760fc07f99a5227c7c6e6272ebe.tar.bz2
gentoo-96a7850b106fa760fc07f99a5227c7c6e6272ebe.zip
dev-php/PEAR-Services_W3C_CSSValidator: new version 0.2.3.
This new version is the latest one from upstream, dating back to 2012(!). Somehow, this package still works well. In the new version, I've dropped the php-pear-r1 eclass, which greatly overcomplicated things. This package doesn't depend directly on PEAR, so some useless eclass RDEPENDs were dropped, and now the examples are installed in the correct location too. Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-php/PEAR-Services_W3C_CSSValidator/PEAR-Services_W3C_CSSValidator-0.2.3.ebuild')
-rw-r--r--dev-php/PEAR-Services_W3C_CSSValidator/PEAR-Services_W3C_CSSValidator-0.2.3.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-php/PEAR-Services_W3C_CSSValidator/PEAR-Services_W3C_CSSValidator-0.2.3.ebuild b/dev-php/PEAR-Services_W3C_CSSValidator/PEAR-Services_W3C_CSSValidator-0.2.3.ebuild
new file mode 100644
index 000000000000..bd51e9c1d512
--- /dev/null
+++ b/dev-php/PEAR-Services_W3C_CSSValidator/PEAR-Services_W3C_CSSValidator-0.2.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+MY_PN="${PN/PEAR-/}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Provides an object oriented interface for the W3 CSS Validator"
+HOMEPAGE="http://pear.php.net/package/${MY_PN}"
+SRC_URI="http://download.pear.php.net/package/${MY_P}.tgz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND="dev-lang/php:*
+ dev-php/PEAR-HTTP_Request2"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ use examples && dodoc -r docs/examples
+
+ insinto /usr/share/php
+ doins -r Services
+}