summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2017-01-06 15:09:22 -0500
committerMichael Orlitzky <mjo@gentoo.org>2017-01-06 15:09:39 -0500
commita1a79b178e30a746a16538f9f8e274e8173738cd (patch)
tree1c8eb0e07b3f741d7717052dc5d63e3e68a45970 /dev-php/PEAR-Text_Highlighter/PEAR-Text_Highlighter-0.7.3-r1.ebuild
parentnet-irc/irssi: Version bump (diff)
downloadgentoo-a1a79b178e30a746a16538f9f8e274e8173738cd.tar.gz
gentoo-a1a79b178e30a746a16538f9f8e274e8173738cd.tar.bz2
gentoo-a1a79b178e30a746a16538f9f8e274e8173738cd.zip
dev-php/PEAR-Text_Highlighter: new revision sans the php-pear-r1 eclass.
This new revision drops php-pear-r1.eclass, and in the process fixes a few bugs. We no longer install all of the development junk, which eliminates the /usr/bin/generate executable (used to generate the PHP classes), and avoids a file collision with app-accessibility/julius. We also now store the documentation in the correct location. One extraneous dependency was removed, and another undocumented one added. Gentoo-Bug: 544514 Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-php/PEAR-Text_Highlighter/PEAR-Text_Highlighter-0.7.3-r1.ebuild')
-rw-r--r--dev-php/PEAR-Text_Highlighter/PEAR-Text_Highlighter-0.7.3-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-php/PEAR-Text_Highlighter/PEAR-Text_Highlighter-0.7.3-r1.ebuild b/dev-php/PEAR-Text_Highlighter/PEAR-Text_Highlighter-0.7.3-r1.ebuild
new file mode 100644
index 000000000000..d510d70cd99c
--- /dev/null
+++ b/dev-php/PEAR-Text_Highlighter/PEAR-Text_Highlighter-0.7.3-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+MY_PN="${PN/PEAR-/}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A package for syntax highlighting"
+HOMEPAGE="http://pear.php.net/package/${MY_PN}"
+SRC_URI="http://download.pear.php.net/package/${MY_P}.tgz"
+LICENSE="PHP-3.01"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# There is a documented dependency on XML_Parser, but that's only needed
+# for development -- if you want to *generate* the PHP class files. The
+# ones in the release are already pre-generated. The dependency on the
+# XML_Serializer, on the other hand, is not documented but is requird
+# by the XML output renderer.
+RDEPEND="dev-lang/php
+ dev-php/PEAR-PEAR
+ dev-php/PEAR-XML_Serializer"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ dodoc README TODO
+
+ insinto /usr/share/php
+ doins -r Text
+}