summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2018-02-14 12:52:37 -0500
committerBrian Evans <grknight@gentoo.org>2018-02-14 12:52:37 -0500
commit852388e03888fafa383aaede9c8c564a6189344b (patch)
tree9a1ccc3a8204d7f23307ae1550c4488b79b80020 /dev-php/PEAR-Validate
parentsci-geosciences/gpxsee: initial import (diff)
downloadgentoo-852388e03888fafa383aaede9c8c564a6189344b.tar.gz
gentoo-852388e03888fafa383aaede9c8c564a6189344b.tar.bz2
gentoo-852388e03888fafa383aaede9c8c564a6189344b.zip
dev-php/PEAR-Validate: Revbump for EAPI, eclass changes and add tests
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-php/PEAR-Validate')
-rw-r--r--dev-php/PEAR-Validate/PEAR-Validate-0.8.5-r1.ebuild22
-rw-r--r--dev-php/PEAR-Validate/files/0.8.5-fix-test-php7.patch19
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-php/PEAR-Validate/PEAR-Validate-0.8.5-r1.ebuild b/dev-php/PEAR-Validate/PEAR-Validate-0.8.5-r1.ebuild
new file mode 100644
index 000000000000..e8e5e342cc58
--- /dev/null
+++ b/dev-php/PEAR-Validate/PEAR-Validate-0.8.5-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit php-pear-r2
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+
+DESCRIPTION="Validation class"
+LICENSE="BSD"
+SLOT="0"
+IUSE="minimal test"
+
+DEPEND="test? ( dev-php/PEAR-PEAR dev-php/PEAR-Date )"
+RDEPEND="!minimal? ( dev-php/PEAR-Date )"
+PATCHES=( "${FILESDIR}/0.8.5-fix-test-php7.patch" )
+HTML_DOCS=( docs/Example_Locale.php docs/sample_multiple.php )
+
+src_test() {
+ peardev run-tests tests || die
+}
diff --git a/dev-php/PEAR-Validate/files/0.8.5-fix-test-php7.patch b/dev-php/PEAR-Validate/files/0.8.5-fix-test-php7.patch
new file mode 100644
index 000000000000..069c5467d049
--- /dev/null
+++ b/dev-php/PEAR-Validate/files/0.8.5-fix-test-php7.patch
@@ -0,0 +1,19 @@
+From a22b5cf2c7e4b4cf366c311150721961d9b456ea Mon Sep 17 00:00:00 2001
+From: Christian Weiske <cweiske@cweiske.de>
+Date: Thu, 16 Jul 2015 00:38:55 +0200
+Subject: [PATCH] Make tests run on PHP 7
+
+diff --git a/Validate.php b/Validate.php
+index a8f621c..ea6cfa7 100644
+--- a/Validate.php
++++ b/Validate.php
+@@ -583,7 +583,8 @@ function email($email, $options = null)
+ if ($use_rfc822? Validate::__emailRFC822($email, $options) :
+ preg_match($regex, $email)) {
+ if ($check_domain && function_exists('checkdnsrr')) {
+- $domain = preg_replace('/[^-a-z.0-9]/i', '', array_pop(explode('@', $email)));
++ $parts = explode('@', $email);
++ $domain = preg_replace('/[^-a-z.0-9]/i', '', array_pop($parts));
+ if (checkdnsrr($domain, 'MX') || checkdnsrr($domain, 'A')) {
+ return true;
+ }