summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2017-03-03 14:15:13 -0500
committerBrian Evans <grknight@gentoo.org>2017-03-03 14:29:20 -0500
commit87b4dc0421814177f2c415b057c5d22346435def (patch)
treebd11294de27ee17675a17c7519df0b793cbcc7d3 /dev-php/PEAR-Var_Dump
parentdev-php/PEAR-Pager: Revision bump for new eclass (diff)
downloadgentoo-87b4dc0421814177f2c415b057c5d22346435def.tar.gz
gentoo-87b4dc0421814177f2c415b057c5d22346435def.tar.bz2
gentoo-87b4dc0421814177f2c415b057c5d22346435def.zip
dev-php/PEAR-Var_Dump: Revision bump for new eclass
Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'dev-php/PEAR-Var_Dump')
-rw-r--r--dev-php/PEAR-Var_Dump/PEAR-Var_Dump-1.0.4-r3.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-php/PEAR-Var_Dump/PEAR-Var_Dump-1.0.4-r3.ebuild b/dev-php/PEAR-Var_Dump/PEAR-Var_Dump-1.0.4-r3.ebuild
new file mode 100644
index 000000000000..707cff167f52
--- /dev/null
+++ b/dev-php/PEAR-Var_Dump/PEAR-Var_Dump-1.0.4-r3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit php-pear-r2
+
+DESCRIPTION="Dump structured information about a variable"
+LICENSE="PHP-3.01"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="examples test"
+
+DEPEND="test? ( dev-php/PEAR-PEAR )"
+
+# The test suite fails due to some deprecation warnings that are output.
+# The test cases themselves set error_reporting(E_ALL), so there's no
+# easy way to override it.
+RESTRICT=test
+
+src_install() {
+ use examples && dodoc -r docs/example*.php
+ php-pear-r2_src_install
+}
+
+src_test() {
+ # Requires the "pear" executable from dev-php/PEAR-PEAR.
+ pear run-tests tests || die
+
+ # The command succeeds regardless of whether or not the test suite
+ # passed, but this file is only written when there was a failure.
+ [[ -f run-tests.log ]] && die "test suite failed"
+}