summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2017-01-04 20:13:32 -0500
committerMichael Orlitzky <mjo@gentoo.org>2017-01-04 20:13:32 -0500
commitcf5ef14a19396a61ea2905aaf00851b9d51b17cd (patch)
treeca6b51308ecfc2ec628cdbf626634708422f9b80 /dev-php/adodb/adodb-5.20.9.ebuild
parentdev-php/pecl-mongo: new revision 1.6.14-r1 dropping php:5.5 support. (diff)
downloadgentoo-cf5ef14a19396a61ea2905aaf00851b9d51b17cd.tar.gz
gentoo-cf5ef14a19396a61ea2905aaf00851b9d51b17cd.tar.bz2
gentoo-cf5ef14a19396a61ea2905aaf00851b9d51b17cd.zip
dev-php/adodb: new v5.20.9 fixing CVE-2016-4855 and CVE-2016-7405.
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-php/adodb/adodb-5.20.9.ebuild')
-rw-r--r--dev-php/adodb/adodb-5.20.9.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-php/adodb/adodb-5.20.9.ebuild b/dev-php/adodb/adodb-5.20.9.ebuild
new file mode 100644
index 000000000000..9732482b905b
--- /dev/null
+++ b/dev-php/adodb/adodb-5.20.9.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+MY_PN="ADOdb"
+DESCRIPTION="Database abstraction layer for PHP"
+HOMEPAGE="http://www.adodb.org/"
+SRC_URI="https://github.com/${MY_PN}/${MY_PN}/archive/v${PV}.tar.gz"
+
+LICENSE="BSD LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+# If you want to be picky, we should require that PHP be built with at
+# least one database driver enabled; otherwise adodb isn't going to be
+# able to do anything. But, the database USE flags for dev-lang/php are
+# a mess. What we would *like* to do is have a set of USE flags for
+# adodb that then propagate to PHP itself... for example, adodb[mysql]
+# could require php[mysql]. To do that would require that we duplicate
+# the database USE flag mess for adodb -- not desirable. Instead we punt
+# and let the user install adodb unconditionally. If he doesn't have
+# database support in PHP, it just won't work.
+RDEPEND="dev-lang/php:*"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_install() {
+ DOCS="README.md docs/changelog*.md xmlschema*.dtd session/*.sql"
+ DOCS+=" session/*.txt session/*.xml pear/auth_adodb_example.php"
+ DOCS+=" pear/readme.Auth.txt"
+
+ dodoc $DOCS
+ rm -f $DOCS || die "failed to remove docs before installation"
+
+ insinto "/usr/share/php/${PN}"
+ doins *.php
+ doins -r contrib datadict drivers lang pear perf replicate session xsl
+}