summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2017-03-09 10:33:53 -0500
committerBrian Evans <grknight@gentoo.org>2017-03-09 11:21:59 -0500
commit7ef93269fd27ce89c5f46e21d3132362add4cf5f (patch)
tree41c06ec2b5c25e26d4778c11df1c8f60eff6c65a /dev-php/doctrine-instantiator/doctrine-instantiator-1.0.5.ebuild
parentdev-php/sebastian-code-unit-reverse-lookup: New package for an unbundled phpunit (diff)
downloadgentoo-7ef93269fd27ce89c5f46e21d3132362add4cf5f.tar.gz
gentoo-7ef93269fd27ce89c5f46e21d3132362add4cf5f.tar.bz2
gentoo-7ef93269fd27ce89c5f46e21d3132362add4cf5f.zip
dev-php/doctrine-instantiator: New package for an unbundled phpunit
Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'dev-php/doctrine-instantiator/doctrine-instantiator-1.0.5.ebuild')
-rw-r--r--dev-php/doctrine-instantiator/doctrine-instantiator-1.0.5.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-php/doctrine-instantiator/doctrine-instantiator-1.0.5.ebuild b/dev-php/doctrine-instantiator/doctrine-instantiator-1.0.5.ebuild
new file mode 100644
index 000000000000..6df2380501b2
--- /dev/null
+++ b/dev-php/doctrine-instantiator/doctrine-instantiator-1.0.5.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="${PN/doctrine-//}"
+
+DESCRIPTION="Utility to instantiate objects in PHP without invoking their constructors"
+HOMEPAGE="https://github.com/doctrine/${MY_PN}"
+SRC_URI="https://github.com/doctrine/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+RDEPEND="dev-php/fedora-autoloader
+ >=dev-lang/php-5.6:*"
+
+src_install() {
+ insinto /usr/share/php/
+ doins -r src/*
+ insinto /usr/share/php/Doctrine/Instantiator
+ doins "${FILESDIR}/autoload.php"
+}