summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-06-15 01:27:40 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-06-15 01:30:30 +0200
commitd1447e075193adf7aeb472bee09bdc959989afb1 (patch)
tree3467a7f3e2b6c6c2db9be2c53b4a02fc90161758 /dev-php/doctrine-instantiator/doctrine-instantiator-1.3.1.ebuild
parentdev-php/json-schema: bump to v5.2.10 (diff)
downloadgentoo-d1447e075193adf7aeb472bee09bdc959989afb1.tar.gz
gentoo-d1447e075193adf7aeb472bee09bdc959989afb1.tar.bz2
gentoo-d1447e075193adf7aeb472bee09bdc959989afb1.zip
dev-php/doctrine-instantiator: bump to v1.3.1
Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php/doctrine-instantiator/doctrine-instantiator-1.3.1.ebuild')
-rw-r--r--dev-php/doctrine-instantiator/doctrine-instantiator-1.3.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-php/doctrine-instantiator/doctrine-instantiator-1.3.1.ebuild b/dev-php/doctrine-instantiator/doctrine-instantiator-1.3.1.ebuild
new file mode 100644
index 000000000000..6b79666dab62
--- /dev/null
+++ b/dev-php/doctrine-instantiator/doctrine-instantiator-1.3.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="${PN/doctrine-//}"
+
+DESCRIPTION="Utility to instantiate objects in PHP without invoking their constructors"
+HOMEPAGE="https://github.com/doctrine/instantiator"
+SRC_URI="https://github.com/doctrine/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+RDEPEND="dev-php/fedora-autoloader
+ >=dev-lang/php-7.1:*"
+
+src_install() {
+ insinto /usr/share/php/
+ doins -r src/*
+ insinto /usr/share/php/Doctrine/Instantiator
+ doins "${FILESDIR}/autoload.php"
+}