summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-02-18 16:26:12 +0100
committerThomas Deutschmann <whissi@gentoo.org>2020-02-18 16:26:51 +0100
commit5a91e43dec8969c86faf7fc49f40adfe6c5c88e5 (patch)
tree7ec987b4a83d8777a7b9290928b64e4789160df5 /dev-php/fedora-autoloader/fedora-autoloader-1.0.1.ebuild
parentdev-python/pybluez: bump (diff)
downloadgentoo-5a91e43dec8969c86faf7fc49f40adfe6c5c88e5.tar.gz
gentoo-5a91e43dec8969c86faf7fc49f40adfe6c5c88e5.tar.bz2
gentoo-5a91e43dec8969c86faf7fc49f40adfe6c5c88e5.zip
dev-php/fedora-autoloader: bump to v1.0.1
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php/fedora-autoloader/fedora-autoloader-1.0.1.ebuild')
-rw-r--r--dev-php/fedora-autoloader/fedora-autoloader-1.0.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-php/fedora-autoloader/fedora-autoloader-1.0.1.ebuild b/dev-php/fedora-autoloader/fedora-autoloader-1.0.1.ebuild
new file mode 100644
index 000000000000..81eea1238509
--- /dev/null
+++ b/dev-php/fedora-autoloader/fedora-autoloader-1.0.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Fedora's Static PSR-4, PSR-0, and classmap autoloader"
+HOMEPAGE="https://github.com/php-fedora/autoloader"
+SRC_URI="https://github.com/php-fedora/autoloader/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+
+IUSE="test"
+
+RESTRICT="test"
+
+RDEPEND="dev-lang/php:*"
+DEPEND="
+ test? (
+ ${RDEPEND}
+ dev-php/phpunit )"
+
+S="${WORKDIR}/autoloader-${PV}"
+
+src_install() {
+ insinto "/usr/share/php/Fedora/Autoloader"
+ doins -r src/.
+ dodoc CHANGELOG.md README.md
+}
+
+src_test() {
+ phpunit || die "test suite failed"
+}