summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2022-12-12 12:07:05 -0500
committerBrian Evans <grknight@gentoo.org>2022-12-12 12:07:05 -0500
commitcc0ae0f4156e02def719aeb697d40ede1f4ecd77 (patch)
tree41532620b9f34f159b895f3868076ed4ebe6336c /dev-php/geos-php/geos-php-1.0.0_p20220909.ebuild
parentnet-misc/gallery-dl: Stabilize 1.23.5 arm64, #885603 (diff)
downloadgentoo-cc0ae0f4156e02def719aeb697d40ede1f4ecd77.tar.gz
gentoo-cc0ae0f4156e02def719aeb697d40ede1f4ecd77.tar.bz2
gentoo-cc0ae0f4156e02def719aeb697d40ede1f4ecd77.zip
dev-php/geos-php: Add new snapshot
Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'dev-php/geos-php/geos-php-1.0.0_p20220909.ebuild')
-rw-r--r--dev-php/geos-php/geos-php-1.0.0_p20220909.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-php/geos-php/geos-php-1.0.0_p20220909.ebuild b/dev-php/geos-php/geos-php-1.0.0_p20220909.ebuild
new file mode 100644
index 000000000000..230ada5c529e
--- /dev/null
+++ b/dev-php/geos-php/geos-php-1.0.0_p20220909.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+PHP_EXT_NAME="geos"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+
+USE_PHP="php7-4 php8-0 php8-1 php8-2"
+
+S="${WORKDIR}/php-geos"
+
+inherit php-ext-source-r3
+
+KEYWORDS="~amd64 ~x86"
+SNAPSHOT="ee5ca8f3739a4e3c1cdeb0abf4f1a47d9ca751a5"
+DESCRIPTION="A PHP interface to GEOS - Geometry Engine, Open Source"
+HOMEPAGE="https://libgeos.org/"
+SRC_URI="https://git.osgeo.org/gitea/geos/php-geos/archive/${SNAPSHOT}.tar.gz -> ${P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+RDEPEND="sci-libs/geos[-php(-)]"
+DEPEND="sci-libs/geos[-php(-)]"
+DOCS=( README.md CREDITS NEWS TODO )
+PHP_EXT_ECONF_ARGS=()
+
+src_prepare() {
+ # Test always fails with geos-3.8 or greater
+ rm "${S}/tests/001_Geometry.phpt" || die
+ php-ext-source-r3_src_prepare
+}