summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-11-17 21:44:26 +0100
committerThomas Deutschmann <whissi@gentoo.org>2019-11-17 22:01:27 +0100
commit324eb009b835fb36952c4d3925ebcd9ae2da886a (patch)
tree4783b06a8e93e636fe62fc228b546e779963b4ec /dev-php/jsonlint
parentdev-php/json-schema: bump to v5.2.9 (diff)
downloadgentoo-324eb009b835fb36952c4d3925ebcd9ae2da886a.tar.gz
gentoo-324eb009b835fb36952c4d3925ebcd9ae2da886a.tar.bz2
gentoo-324eb009b835fb36952c4d3925ebcd9ae2da886a.zip
dev-php/jsonlint: bump to v1.7.2
Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php/jsonlint')
-rw-r--r--dev-php/jsonlint/Manifest1
-rw-r--r--dev-php/jsonlint/jsonlint-1.7.2.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-php/jsonlint/Manifest b/dev-php/jsonlint/Manifest
index 3c259a33e1c3..b21b6e07dab0 100644
--- a/dev-php/jsonlint/Manifest
+++ b/dev-php/jsonlint/Manifest
@@ -1 +1,2 @@
DIST jsonlint-1.7.1.tar.gz 11813 BLAKE2B ed1a1404cf77d526a5dce15d0a3f36c5ff8c691e3d2560b6b5e309108d6f0072988b292fd1410b48bfad4ba528abd854204c38bf36f5196c7d8beb468716a5db SHA512 dd8380d02591997a129dc8f25f3b2f7c2f00c1d280bdce6551079b564b54b4828beb929bd9a7c608be6429754eb1c33d2d655a0f87b8f671ccf26ee2ae46095d
+DIST jsonlint-1.7.2.tar.gz 11915 BLAKE2B 4fb1bb526c64ad2db442bca4c2c609e7d589ed84c372291a7bb71edcf63d246be821d78fe246b1660444f99fe9dd3408f01841fc9d687654d2bcc45dc9337c91 SHA512 ac5a135b1940799b07c31c2b05b0c782d0409dbf93e93013f1cb69f8423d1913b93c18988f1a03781da4c29d28de35eee6a76a2f18c81cd049696f779045cafb
diff --git a/dev-php/jsonlint/jsonlint-1.7.2.ebuild b/dev-php/jsonlint/jsonlint-1.7.2.ebuild
new file mode 100644
index 000000000000..4085b18b49f7
--- /dev/null
+++ b/dev-php/jsonlint/jsonlint-1.7.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="JSON Lint for PHP"
+HOMEPAGE="https://github.com/Seldaek/jsonlint"
+SRC_URI="https://github.com/Seldaek/jsonlint/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="test"
+
+RDEPEND="
+ dev-lang/php:*
+ dev-php/fedora-autoloader"
+DEPEND="
+ test? (
+ ${RDEPEND}
+ dev-php/phpunit )"
+
+src_prepare() {
+ default
+ if use test; then
+ cp "${FILESDIR}"/autoload.php "${S}"/autoload-test.php || die
+ sed -i -e "s:__DIR__:'${S}/src/Seld/JsonLint':" "${S}"/autoload-test.php || die
+ fi
+}
+
+src_install() {
+ insinto "/usr/share/php/Seld/JsonLint"
+ doins -r src/Seld/JsonLint/. "${FILESDIR}"/autoload.php
+ dodoc README.md
+}
+
+src_test() {
+ phpunit --bootstrap "${S}"/autoload-test.php || die "test suite failed"
+}