summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2016-11-28 13:21:20 -0500
committerBrian Evans <grknight@gentoo.org>2016-11-28 14:37:20 -0500
commita1cb627b2033f0a62c54b937ccd503a0225c77a2 (patch)
tree788224d3d039f96a55848c9613407d89b343a79a /dev-php/magickwand/magickwand-1.0.9-r2.ebuild
parentapp-admin/calamares: Remove 2.4.4 (diff)
downloadgentoo-a1cb627b2033f0a62c54b937ccd503a0225c77a2.tar.gz
gentoo-a1cb627b2033f0a62c54b937ccd503a0225c77a2.tar.bz2
gentoo-a1cb627b2033f0a62c54b937ccd503a0225c77a2.zip
dev-php/magickwand: Revbump to drop php 5.4 and 5.5 dependencies
This package has not been ported and fails with PHP 7.0. Patches are welcome, but this package is in danger of being dropped when PHP 5.6 becomes obsolete. Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-php/magickwand/magickwand-1.0.9-r2.ebuild')
-rw-r--r--dev-php/magickwand/magickwand-1.0.9-r2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-php/magickwand/magickwand-1.0.9-r2.ebuild b/dev-php/magickwand/magickwand-1.0.9-r2.ebuild
new file mode 100644
index 000000000000..77a9174a58b1
--- /dev/null
+++ b/dev-php/magickwand/magickwand-1.0.9-r2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PHP_EXT_NAME="magickwand"
+PHP_EXT_ZENDEXT="no"
+PHP_EXT_INI="yes"
+DOCS=( AUTHOR ChangeLog CREDITS README TODO )
+
+MY_PN="MagickWandForPHP"
+IUSE=""
+
+USE_PHP="php5-6"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+inherit php-ext-source-r3
+
+DESCRIPTION="A native PHP-extension to the ImageMagick MagickWand API"
+HOMEPAGE="http://www.magickwand.org/"
+SRC_URI="http://www.magickwand.org/download/php/${MY_PN}-${PV}-2.tar.bz2"
+
+LICENSE="MagickWand"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=media-gfx/imagemagick-6.5.2.9"
+RDEPEND="${DEPEND}"