summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-06-07 14:15:11 +0200
committerThomas Deutschmann <whissi@gentoo.org>2019-06-07 16:07:50 +0200
commit7f5592301502852ba9a645d09eb3ac73cff051d5 (patch)
tree12302ea1b8b955f7a9277387dc923f09d948cefc /dev-php/pecl-apcu_bc/pecl-apcu_bc-1.0.5.ebuild
parentdev-php/pecl-taint: bump to v2.0.5 (diff)
downloadgentoo-7f5592301502852ba9a645d09eb3ac73cff051d5.tar.gz
gentoo-7f5592301502852ba9a645d09eb3ac73cff051d5.tar.bz2
gentoo-7f5592301502852ba9a645d09eb3ac73cff051d5.zip
dev-php/pecl-apcu_bc: bump to v1.0.5
Package-Manager: Portage-2.3.67, Repoman-2.3.14 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php/pecl-apcu_bc/pecl-apcu_bc-1.0.5.ebuild')
-rw-r--r--dev-php/pecl-apcu_bc/pecl-apcu_bc-1.0.5.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-php/pecl-apcu_bc/pecl-apcu_bc-1.0.5.ebuild b/dev-php/pecl-apcu_bc/pecl-apcu_bc-1.0.5.ebuild
new file mode 100644
index 000000000000..2e08b7e24a57
--- /dev/null
+++ b/dev-php/pecl-apcu_bc/pecl-apcu_bc-1.0.5.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PHP_INI_NAME="bc_apc"
+PHP_EXT_NAME="apc"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+PHP_EXT_EXTRA_ECONF=""
+DOCS=( README.md )
+
+USE_PHP="php7-1 php7-2 php7-3"
+
+inherit php-ext-pecl-r3 multilib
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Provides APC backwards compatibility functions via APCu"
+LICENSE="PHP-3.01"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-php/pecl-apcu:7[php_targets_php7-1?,php_targets_php7-2?,php_targets_php7-3?]"
+RDEPEND="${DEPEND}"
+
+src_test() {
+ # This fixed version is necessary to have apcu load
+ # from the install before the tested apc.
+ # It is intentional to specify phpoptions twice.
+ # This mimics the Makefile.
+ local slot phpoptions
+ for slot in $(php_get_slots); do
+ php_init_slot_env "${slot}"
+ ln -s "${EXT_DIR}/apcu$(get_libname)" \
+ "modules/" || die
+ phpoptions=( -n -d extension_dir="${PHP_EXT_S}/modules"
+ -d extension=apcu$(get_libname)
+ -d extension=apc$(get_libname) )
+ NO_INTERACTION="yes" TEST_PHP_EXECUTABLE="${PHPCLI}" \
+ "${PHPCLI}" "${phpoptions[@]}" \
+ run-tests.php "${phpoptions[@]}" || die
+ done
+}