summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2018-04-09 09:49:43 -0400
committerBrian Evans <grknight@gentoo.org>2018-04-09 11:08:16 -0400
commita225f4a62857d0dd57bb10397b22041cec9de410 (patch)
tree660992a5752b05a491e848a1cf94c03e89b75028 /dev-php/pecl-dbase/pecl-dbase-7.0.0_beta1-r1.ebuild
parentdev-php/pecl-dio: Drop old (diff)
downloadgentoo-a225f4a62857d0dd57bb10397b22041cec9de410.tar.gz
gentoo-a225f4a62857d0dd57bb10397b22041cec9de410.tar.bz2
gentoo-a225f4a62857d0dd57bb10397b22041cec9de410.zip
dev-php/pecl-dbase: Revbump for php 7.2
Package-Manager: Portage-2.3.28, Repoman-2.3.9
Diffstat (limited to 'dev-php/pecl-dbase/pecl-dbase-7.0.0_beta1-r1.ebuild')
-rw-r--r--dev-php/pecl-dbase/pecl-dbase-7.0.0_beta1-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-php/pecl-dbase/pecl-dbase-7.0.0_beta1-r1.ebuild b/dev-php/pecl-dbase/pecl-dbase-7.0.0_beta1-r1.ebuild
new file mode 100644
index 000000000000..72bf7b340134
--- /dev/null
+++ b/dev-php/pecl-dbase/pecl-dbase-7.0.0_beta1-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# Define 5.6 here so we get the USE and REQUIRED_USE from the eclass
+# This allows us to depend on the other slot
+USE_PHP="php5-6 php7-0 php7-1 php7-2"
+
+inherit php-ext-pecl-r3
+
+# However, we only really build for 7.x; so redefine it here
+USE_PHP="php7-0 php7-1 php7-2"
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="dBase database file access functions"
+LICENSE="PHP-3.01"
+SLOT="7"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND} php_targets_php5-6? ( dev-php/pecl-dbase:0[php_targets_php5-6] )"
+
+src_prepare() {
+ if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 ; then
+ php-ext-source-r3_src_prepare
+ else
+ eapply_user
+ fi
+}
+
+src_configure() {
+ if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 ; then
+ local PHP_EXT_ECONF_ARGS=( )
+ php-ext-source-r3_src_configure
+ fi
+}
+
+src_install() {
+ if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 ; then
+ php-ext-pecl-r3_src_install
+ fi
+}