summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-php/pecl-drizzle
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-php/pecl-drizzle')
-rw-r--r--dev-php/pecl-drizzle/Manifest1
-rw-r--r--dev-php/pecl-drizzle/files/pecl-drizzle-0.4.2-php54.patch73
-rw-r--r--dev-php/pecl-drizzle/metadata.xml12
-rw-r--r--dev-php/pecl-drizzle/pecl-drizzle-0.4.2-r3.ebuild35
4 files changed, 121 insertions, 0 deletions
diff --git a/dev-php/pecl-drizzle/Manifest b/dev-php/pecl-drizzle/Manifest
new file mode 100644
index 000000000000..566ff8eea748
--- /dev/null
+++ b/dev-php/pecl-drizzle/Manifest
@@ -0,0 +1 @@
+DIST drizzle-0.4.2.tgz 24106 SHA256 5e9abd5200d840249003112e7d658eda06e2591e4c6bcf1c97194b4e274f0c66 SHA512 39b4d4fd7f68fba0c13e947c5b93179c3d7a4fd563b60c5ae9f7f175a095e16d2344a924cecd8c921892b33d7fe6cb4f95cfccbfbec40be14b1f46b534cba76e WHIRLPOOL 7ff5b373738a755a9ac90b5028eafa5f98a42bd47999e78fda3174c7361929d2d316b46fa28bfb4a2c5a0e370ce211895905605254b9d44999abf53881e138a0
diff --git a/dev-php/pecl-drizzle/files/pecl-drizzle-0.4.2-php54.patch b/dev-php/pecl-drizzle/files/pecl-drizzle-0.4.2-php54.patch
new file mode 100644
index 000000000000..42c27103a67b
--- /dev/null
+++ b/dev-php/pecl-drizzle/files/pecl-drizzle-0.4.2-php54.patch
@@ -0,0 +1,73 @@
+diff -aurN drizzle-0.4.2.orig/php_drizzle.c drizzle-0.4.2/php_drizzle.c
+--- drizzle-0.4.2.orig/php_drizzle.c 1970-01-01 04:13:08.000000000 -0500
++++ drizzle-0.4.2/php_drizzle.c 2014-10-22 21:38:21.882838493 -0400
+@@ -1314,9 +1314,13 @@
+ }
+
+ zend_object_std_init(&(obj->std), class_type TSRMLS_CC);
++#if PHP_VERSION_ID < 50399
+ zend_hash_copy(obj->std.properties, &(class_type->default_properties),
+ (copy_ctor_func_t)zval_add_ref, (void *)(&tmp),
+ sizeof(zval *));
++#else
++ object_properties_init((zend_object*) &(obj->std), class_type);
++#endif
+
+ value.handle= zend_objects_store_put(obj,
+ (zend_objects_store_dtor_t)zend_objects_destroy_object,
+@@ -1582,9 +1586,13 @@
+ }
+
+ zend_object_std_init(&(obj->std), class_type TSRMLS_CC);
++#if PHP_VERSION_ID < 50399
+ zend_hash_copy(obj->std.properties, &(class_type->default_properties),
+ (copy_ctor_func_t)zval_add_ref, (void *)(&tmp),
+ sizeof(zval *));
++#else
++ object_properties_init((zend_object*) &(obj->std), class_type);
++#endif
+
+ obj->value.handle= zend_objects_store_put(obj,
+ (zend_objects_store_dtor_t)zend_objects_destroy_object,
+@@ -2505,9 +2513,13 @@
+ }
+
+ zend_object_std_init(&(obj->std), class_type TSRMLS_CC);
++#if PHP_VERSION_ID < 50399
+ zend_hash_copy(obj->std.properties, &(class_type->default_properties),
+ (copy_ctor_func_t)zval_add_ref, (void *)(&tmp),
+ sizeof(zval *));
++#else
++ object_properties_init((zend_object*) &(obj->std), class_type);
++#endif
+
+ obj->value.handle= zend_objects_store_put(obj,
+ (zend_objects_store_dtor_t)zend_objects_destroy_object,
+@@ -3017,9 +3029,13 @@
+ }
+
+ zend_object_std_init(&(result->std), class_type TSRMLS_CC);
++#if PHP_VERSION_ID < 50399
+ zend_hash_copy(result->std.properties, &(class_type->default_properties),
+ (copy_ctor_func_t)zval_add_ref, (void *)(&tmp),
+ sizeof(zval *));
++#else
++ object_properties_init((zend_object*) &(result->std), class_type);
++#endif
+
+ value.handle= zend_objects_store_put(result,
+ (zend_objects_store_dtor_t)zend_objects_destroy_object,
+@@ -3382,9 +3398,13 @@
+ }
+
+ zend_object_std_init(&(obj->std), class_type TSRMLS_CC);
++#if PHP_VERSION_ID < 50399
+ zend_hash_copy(obj->std.properties, &(class_type->default_properties),
+ (copy_ctor_func_t)zval_add_ref, (void *)(&tmp),
+ sizeof(zval *));
++#else
++ object_properties_init((zend_object*) &(obj->std), class_type);
++#endif
+
+ value.handle= zend_objects_store_put(obj,
+ (zend_objects_store_dtor_t)zend_objects_destroy_object,
diff --git a/dev-php/pecl-drizzle/metadata.xml b/dev-php/pecl-drizzle/metadata.xml
new file mode 100644
index 000000000000..21b6378eedbc
--- /dev/null
+++ b/dev-php/pecl-drizzle/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>pavel.stratil-jun@fenix.cz</email>
+ <description>Proxied co-maintainer, assign bugs to him</description>
+ </maintainer>
+ <maintainer>
+ <email>flameeyes@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-php/pecl-drizzle/pecl-drizzle-0.4.2-r3.ebuild b/dev-php/pecl-drizzle/pecl-drizzle-0.4.2-r3.ebuild
new file mode 100644
index 000000000000..8d1be77b215f
--- /dev/null
+++ b/dev-php/pecl-drizzle/pecl-drizzle-0.4.2-r3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PHP_EXT_NAME="drizzle"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+
+USE_PHP="php5-6 php5-5 php5-4"
+
+inherit php-ext-pecl-r2 eutils
+
+KEYWORDS="~amd64"
+
+DESCRIPTION="PHP extension using libdrizzle library to provide communcation with Drizzle and MySQL databases"
+LICENSE="PHP-3"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-db/drizzle"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ local slot orig_s="${PHP_EXT_S}"
+ for slot in $(php_get_slots); do
+ php_init_slot_env ${slot}
+ epatch "${FILESDIR}/${P}-php54.patch"
+ #Fix tests
+ mkdir ext || die
+ mv drizzle_*.phpt ext || die
+ done
+ php-ext-source-r2_src_prepare
+}