summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2019-10-17 07:44:03 +0300
committerJoonas Niilola <juippis@gentoo.org>2019-10-17 07:51:18 +0300
commitd17be11b90b3e9cdaf7a0fb7743b088e8d6b8cd4 (patch)
tree3ea9993a16b0bd63678abde8fb1141930e6ccb0d /dev-php/pecl-event/pecl-event-2.4.3.ebuild
parentdev-php/pecl-event: bump to 2.5.3 (diff)
downloadgentoo-d17be11b90b3e9cdaf7a0fb7743b088e8d6b8cd4.tar.gz
gentoo-d17be11b90b3e9cdaf7a0fb7743b088e8d6b8cd4.tar.bz2
gentoo-d17be11b90b3e9cdaf7a0fb7743b088e8d6b8cd4.zip
dev-php/pecl-event: clean old
Closes: https://github.com/gentoo/gentoo/pull/13155 Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-php/pecl-event/pecl-event-2.4.3.ebuild')
-rw-r--r--dev-php/pecl-event/pecl-event-2.4.3.ebuild52
1 files changed, 0 insertions, 52 deletions
diff --git a/dev-php/pecl-event/pecl-event-2.4.3.ebuild b/dev-php/pecl-event/pecl-event-2.4.3.ebuild
deleted file mode 100644
index cd49d9bdc6a6..000000000000
--- a/dev-php/pecl-event/pecl-event-2.4.3.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-PHP_EXT_NAME="event"
-PHP_EXT_INI="yes"
-PHP_EXT_ZENDEXT="no"
-DOCS=( README.md )
-
-USE_PHP="php5-6 php7-0 php7-1 php7-2 php7-3"
-
-inherit php-ext-pecl-r3
-
-KEYWORDS="~amd64 ~ia64 ~x86"
-LICENSE="PHP-3.01"
-
-DESCRIPTION="PHP wrapper for libevent2"
-SLOT="0"
-
-DEPEND="
- >=dev-libs/libevent-2.0.2
- ssl? ( !libressl? ( dev-libs/openssl:0= ) libressl? ( dev-libs/libressl:0= ) )
- php_targets_php5-6? ( dev-lang/php:5.6[sockets?] )
- php_targets_php7-0? ( dev-lang/php:7.0[sockets?] )
- php_targets_php7-1? ( dev-lang/php:7.1[sockets?] )
- php_targets_php7-2? ( dev-lang/php:7.2[sockets?] )
- php_targets_php7-3? ( dev-lang/php:7.3[sockets?] )"
-
-RDEPEND="${DEPEND} !dev-php/pecl-libevent"
-
-IUSE="debug examples +extra libressl +sockets +ssl threads"
-
-src_configure() {
- local PHP_EXT_ECONF_ARGS=(
- --with-event-core
- $(use_enable debug event-debug)
- $(use_with extra event-extra)
- $(use_with ssl event-openssl)
- $(use_with threads event-pthreads)
- $(use_enable sockets event-sockets)
- )
- php-ext-source-r3_src_configure
-}
-
-src_test() {
- local slot
- for slot in $(php_get_slots); do
- php_init_slot_env "${slot}"
- SKIP_ONLINE_TESTS="yes" NO_INTERACTION="yes" emake test
- done
-}