summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-06-12 14:49:37 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-06-12 14:50:20 +0200
commit09861985306c4122c5b8e2f2a9d2c7c621f420ba (patch)
treefb262a4f064320c8948710922a2d14803d9e4876 /dev-php/pecl-haru
parentnet-libs/ntirpc: Removed old. (diff)
downloadgentoo-09861985306c4122c5b8e2f2a9d2c7c621f420ba.tar.gz
gentoo-09861985306c4122c5b8e2f2a9d2c7c621f420ba.tar.bz2
gentoo-09861985306c4122c5b8e2f2a9d2c7c621f420ba.zip
dev-php/pecl-haru: Drop USE png, zlib
media-libs/libharu-2.3.0-r2 lost these flags for some reason. Package-Manager: Portage-2.3.67, Repoman-2.3.14 RepoMan-Options: --force Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-php/pecl-haru')
-rw-r--r--dev-php/pecl-haru/pecl-haru-1.0.4-r3.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-php/pecl-haru/pecl-haru-1.0.4-r3.ebuild b/dev-php/pecl-haru/pecl-haru-1.0.4-r3.ebuild
new file mode 100644
index 000000000000..44313c4831bb
--- /dev/null
+++ b/dev-php/pecl-haru/pecl-haru-1.0.4-r3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_PHP="php5-6"
+
+inherit php-ext-pecl-r3
+
+DESCRIPTION="An interface to libharu, a PDF generator"
+
+LICENSE="PHP-3.01"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="media-libs/libharu[png(+),zlib(+)]"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ # config.m4 is broken checking paths, so we need to override it
+ local PHP_EXT_ECONF_ARGS=(
+ --with-png-dir=/usr
+ --with-zlib-dir=/usr
+ )
+
+ php-ext-source-r3_src_configure
+}