summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-php/pecl-htscanner
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-php/pecl-htscanner')
-rw-r--r--dev-php/pecl-htscanner/Manifest1
-rw-r--r--dev-php/pecl-htscanner/metadata.xml5
-rw-r--r--dev-php/pecl-htscanner/pecl-htscanner-1.0.1-r2.ebuild43
3 files changed, 49 insertions, 0 deletions
diff --git a/dev-php/pecl-htscanner/Manifest b/dev-php/pecl-htscanner/Manifest
new file mode 100644
index 000000000000..68b51357fdb7
--- /dev/null
+++ b/dev-php/pecl-htscanner/Manifest
@@ -0,0 +1 @@
+DIST htscanner-1.0.1.tgz 10229 SHA256 c894e6bccc258ac1601530292e949991a355b68650d70cb9dba303df48a7823f SHA512 c0ccc0e4c945806364d5fd162c901bb9a44afe9eeedca864ca30f9fda430e60bf86d4ef41c0540639252c215eb72b1d34b28eba823aaeb64217bd9400a99f22e WHIRLPOOL 5fd196bdcb76a3ccfe9dc05cedfa783be16bfe4fc77a98d4e7e6de641210dde8258770f6194bc773f4ee500b4c3e86eb5bc66f0e6c85135b04352e3748fd0650
diff --git a/dev-php/pecl-htscanner/metadata.xml b/dev-php/pecl-htscanner/metadata.xml
new file mode 100644
index 000000000000..40dbb4c4bbaf
--- /dev/null
+++ b/dev-php/pecl-htscanner/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>php</herd>
+</pkgmetadata>
diff --git a/dev-php/pecl-htscanner/pecl-htscanner-1.0.1-r2.ebuild b/dev-php/pecl-htscanner/pecl-htscanner-1.0.1-r2.ebuild
new file mode 100644
index 000000000000..fa225b1adb76
--- /dev/null
+++ b/dev-php/pecl-htscanner/pecl-htscanner-1.0.1-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PHP_EXT_NAME="htscanner"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS="README"
+PHPSAPILIST="cgi"
+
+USE_PHP="php5-6 php5-5 php5-4"
+
+inherit php-ext-pecl-r2
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Enables .htaccess options for php-scripts running as cgi"
+LICENSE="PHP-3"
+SLOT="0"
+IUSE=""
+
+for target in ${USE_PHP}; do
+ slot=${target/php}
+ slot=${slot/-/.}
+ PHPUSEDEPEND="${PHPUSEDEPEND}
+ php_targets_${target}? ( dev-lang/php:${slot}[cgi] )"
+done
+
+DEPEND="${PHPUSEDEPEND}"
+RDEPEND="${DEPEND}"
+
+my_conf="--enable-htscanner"
+
+src_install() {
+ php-ext-pecl-r2_src_install
+
+ php-ext-source-r2_addtoinifiles "config_file" ".htaccess"
+ php-ext-source-r2_addtoinifiles "default_docroot" "/"
+ php-ext-source-r2_addtoinifiles "default_ttl" "300"
+ php-ext-source-r2_addtoinifiles "stop_on_error" "0"
+}