summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2015-08-24 12:59:03 -0400
committerMichael Orlitzky <mjo@gentoo.org>2015-08-24 13:00:19 -0400
commit2abc4e886ab557f00981e3ab7f9bcf94691c1c6a (patch)
tree3aae4cd43208dd6c36c7bb9effcef136435d77ef /dev-php/pecl-imagick/pecl-imagick-3.3.0_rc2.ebuild
parentmedia-video/ffmpeg: Add sidxindex tool. (diff)
downloadgentoo-2abc4e886ab557f00981e3ab7f9bcf94691c1c6a.tar.gz
gentoo-2abc4e886ab557f00981e3ab7f9bcf94691c1c6a.tar.bz2
gentoo-2abc4e886ab557f00981e3ab7f9bcf94691c1c6a.zip
dev-php/pecl-imagick: version bump adding partial prefix support.
Bump to v3.3.0 RC2. This also adds an $EPREFIX to the --with-imagick parameter. This isn't enough to get prefix support, but it will be needed eventually. Bug: 371985 Bug: 481410 Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-php/pecl-imagick/pecl-imagick-3.3.0_rc2.ebuild')
-rw-r--r--dev-php/pecl-imagick/pecl-imagick-3.3.0_rc2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-php/pecl-imagick/pecl-imagick-3.3.0_rc2.ebuild b/dev-php/pecl-imagick/pecl-imagick-3.3.0_rc2.ebuild
new file mode 100644
index 000000000000..b433868a5b80
--- /dev/null
+++ b/dev-php/pecl-imagick/pecl-imagick-3.3.0_rc2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DOCS="TODO"
+
+MY_PV="${PV/rc/RC}"
+
+USE_PHP="php5-6 php5-5 php5-4"
+
+inherit php-ext-pecl-r2
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="PHP wrapper for the ImageMagick library"
+LICENSE="PHP-3.01"
+SLOT="0"
+IUSE="examples"
+
+# imagemagick[-openmp] is needed wrt bug 547922 and upstream
+# https://github.com/mkoppanen/imagick#openmp
+DEPEND=">=media-gfx/imagemagick-6.2.4:=[-openmp]"
+RDEPEND="${DEPEND}"
+
+my_conf="--with-imagick=${EPREFIX}/usr"