summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-01-14 15:47:09 +0100
committerThomas Deutschmann <whissi@gentoo.org>2019-01-14 15:47:36 +0100
commit507e6ed891234a0078758860bfa6da1c1a067e99 (patch)
treef21de960165d3dc7a0e0664801fc00c66c5a19f3 /dev-php/pecl-imagick
parentmedia-plugins/kodi-pvr-mediaportal-tvserver: 3.5.15 version bump (diff)
downloadgentoo-507e6ed891234a0078758860bfa6da1c1a067e99.tar.gz
gentoo-507e6ed891234a0078758860bfa6da1c1a067e99.tar.bz2
gentoo-507e6ed891234a0078758860bfa6da1c1a067e99.zip
dev-php/pecl-imagick: bump to snapshot version to add PHP 7.3 support
Package-Manager: Portage-2.3.55, Repoman-2.3.12 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php/pecl-imagick')
-rw-r--r--dev-php/pecl-imagick/Manifest1
-rw-r--r--dev-php/pecl-imagick/files/pecl-imagick-3.4.3-tsrm_ls-is-undeclared.patch18
-rw-r--r--dev-php/pecl-imagick/pecl-imagick-3.4.3_p20181129.ebuild32
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-php/pecl-imagick/Manifest b/dev-php/pecl-imagick/Manifest
index 0d16e2589637..7c89f1f40885 100644
--- a/dev-php/pecl-imagick/Manifest
+++ b/dev-php/pecl-imagick/Manifest
@@ -1 +1,2 @@
DIST imagick-3.4.3.tgz 245410 BLAKE2B 778c3b8ad3ad5e698044a832d71409eea220a82041544abeb88b59370d4b719388ce13b277d7aad84e67e40fcbbfa06d66a2458d4d9e8d33bb7358ab46368230 SHA512 2cb2b856cf83a78d3542cdf7c69554dcc063a0541e9092b24e5e1fbd8928066a4a3de154049d0202c35addbc5055ccfbb5910ae92f2f13da80ddfc025340ddcd
+DIST pecl-imagick-3.4.3_p20181129.tar.gz 260443 BLAKE2B 43d30514f5faeeaa5894e2eb51d5b2ebbe2940728c7770eec60c41c9f01f86f7423d87a71a9ad2068e388f3994c31e499940c2042994846a6b6ab66542c7ea53 SHA512 7f3719118849857d19b9a35a63de68d4e992780fd41231a041d6d152ab2f0abd3d8215ab2362a998f8fe6a733c087d3c3e5d09fa826480d621739e92f5aeabf2
diff --git a/dev-php/pecl-imagick/files/pecl-imagick-3.4.3-tsrm_ls-is-undeclared.patch b/dev-php/pecl-imagick/files/pecl-imagick-3.4.3-tsrm_ls-is-undeclared.patch
new file mode 100644
index 000000000000..ff0a1eb38885
--- /dev/null
+++ b/dev-php/pecl-imagick/files/pecl-imagick-3.4.3-tsrm_ls-is-undeclared.patch
@@ -0,0 +1,18 @@
+https://github.com/mkoppanen/imagick/issues/264
+
+--- a/imagick_file.c
++++ b/imagick_file.c
+@@ -160,11 +160,13 @@ static
+ int php_imagick_read_image_using_imagemagick(php_imagick_object *intern, struct php_imagick_file_t *file, ImagickOperationType type TSRMLS_DC)
+ {
+
++#ifdef ZTS
+ #ifndef ZEND_ENGINE_3
+ #if PHP_VERSION_ID >= 50600
+ // This suppresses an 'unused parameter' warning.
+ (void)tsrm_ls;
+ #endif
++#endif
+ #endif
+
+ if (type == ImagickReadImage) {
diff --git a/dev-php/pecl-imagick/pecl-imagick-3.4.3_p20181129.ebuild b/dev-php/pecl-imagick/pecl-imagick-3.4.3_p20181129.ebuild
new file mode 100644
index 000000000000..e1c86fc73437
--- /dev/null
+++ b/dev-php/pecl-imagick/pecl-imagick-3.4.3_p20181129.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+PHP_EXT_NAME="imagick"
+
+MY_COMMIT="d57a444766a321fa226266f51f1f42ee2cc29cc7"
+
+USE_PHP="php5-6 php7-0 php7-1 php7-2 php7-3"
+
+S="${WORKDIR}/imagick-${MY_COMMIT}"
+
+inherit php-ext-source-r3
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="PHP wrapper for the ImageMagick library"
+HOMEPAGE="https://pecl.php.net/imagick https://github.com/mkoppanen/imagick"
+SRC_URI="https://github.com/mkoppanen/imagick/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+LICENSE="PHP-3.01"
+SLOT="0"
+IUSE="examples test"
+
+# imagemagick[-openmp] is needed wrt bug 547922 and upstream
+# https://github.com/mkoppanen/imagick#openmp
+RDEPEND=">=media-gfx/imagemagick-6.2.4:=[-openmp]"
+DEPEND="${RDEPEND}
+ test? ( >=media-gfx/imagemagick-6.2.4:=[jpeg,png,truetype] )"
+
+PATCHES=( "${FILESDIR}"/${PN}-3.4.3-tsrm_ls-is-undeclared.patch )
+
+PHP_EXT_ECONF_ARGS="--with-imagick=${EPREFIX%/}/usr"